My custom role contains following roles - Sitecore\Designer & Sitecore\Author

Also I tried giving Read/Write access to below items in core database

/sitecore/content/Applications/Content Editor/Ribbons/Chunks/Layout

/sitecore/content/Applications/Content Editor/Ribbons/Chunks/Layout/Details

but still, it is disabled.

  • Are you able to edit the basic fields of the item? I just tested this on one of our systems. I added a custom role that has those two roles added (designer and author), then created a user belonging to this role only. I was able to access the presentation details tab. One thing to note, if the page has a workflow, you need workflow write permission. Once checked out you should be able to see the tab. Commented Dec 2, 2022 at 9:44
  • Sitecore role can override other roles. You need to make sure that when setting the read and write access, there are no other roles which are overriding it. Commented Dec 3, 2022 at 16:07
  • I have the same issue after I installed the KB1001328(sitecore.service-now.com/…) to resolve another issue as per Sitecore recommendation. Just to clarify, I have verified the "Read" access. Before this patch, one with custom role was able to just view the "Details" without locking the item. I have already raised a ticket with Sitecore support but it is getting long time to get a response. So just checking here, whether someone knows a fix for this. Commented Mar 21, 2023 at 15:41

2 Answers 2


In Sitecore, when you assign access rights to items, they always inherit the access right that is assigned to their parent item in the content tree. However, if you need to, you can overrule the inherited rights on an item by assigning access rights specifically on the item or denying the item the right to inherit.

Further details are available on : https://doc.sitecore.com/xp/en/developers/93/platform-administration-and-architecture/assigning-access-rights.html

Also, you can view permission for items and you can troubleshoot permission applied to the item by adjusting the applied permission on the right side in the Access Viewer window. enter image description here


These options can be in a disabled state because the item wasn't locked before editing.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.