1

I have edge graphql endpoint enabled but I noticed that it doesn't do mutations, I'm trying to figure out how to enable the built in systemContent schema for my mutation requests.

Edit I think it's worth noting that my Sitecore environment is running on a local docker instance

Thanks in advance.

1 Answer 1

1

To enable the graphQL endpoint to try the below steps

  1. Download and install packages.
  1. Enable Sitecore.Services.GraphQL.Content.Master.config and deploy to Sitecore instance
  2. Now Try to access with https://my.sitecore.domain/sitecore/api/graph/items/master
  3. If it shows an error message like "{"errors":[{"message":"No query was provided!"}]}" means your endpoint is working now.
  4. You can access GarphQL Ui using: https://my.sitecore.domain/sitecore/api/graph/items/master/ui?sc_apikey={"API-Key"}
  5. It should work fine if you notice an authentication error then here is the fix:Getting "Authentication required" error when attempting to use systemService with Sitecore GraphQL

Hope this helps!

3
  • I found the folder to enable the Sitecore.Services.GraphQL.Content.Master.config in C:\ProgramData\Docker\windowsfilter\{id}\Files\inetpub\wwwroot\App_Config\Sitecore\Services.GraphQL but when I try to run up.ps1 to start my sitecore instance it wouldn't start, I'm not really familiar with docker yet so I'm not quite sure how to edit files in docker. I've seen some docs but it's mainly about editing files inside the src folder, I also can't navigate to the folder via vs docker image explorer Dec 9, 2022 at 10:32
  • You can place it in this path - \YourProjectLocation\docker\deploy\platform\Sitecore.Services.GraphQL.Content.Master.config. Here platform folder is you cm deployment folder. Or you can also create a folder in a structured way like and place it - \deploy\platform\App_Config\Include\z.Services.GraphQL\Sitecore.Services.GraphQL.Content.Master.config Dec 9, 2022 at 10:39
  • Thanks so much! I finally got it working. Dec 9, 2022 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.