1

We are using solr cloud with zookeeper for Sitecore 10.2 environment. We have created xdb and xdb_rebuild collections with aliases xdb_mainalias and xdb_rebuildalias respectively. When we trigger xdb rebuild, it moves all the way till finishing stage (95%) and fails there. When we dig the logs it says

[Error] An error occured during index rebuilding. There will be another attempt to check. The check interval after an error is 00:00:20. 
Sitecore.Xdb.Collection.Search.Solr.Failures.SolrRebuildCoreNotFoundException: Collection name for alias: [xdb_rebuild] not found in Zookeeper configuration.
   at Sitecore.Xdb.Collection.Search.Solr.SolrCloudRebuildHelper.<LoadCollectionNames>d__3.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Sitecore.Xdb.Collection.Search.Solr.SolrCloudRebuildHelper.<SwapCores>d__1.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Sitecore.Xdb.Collection.Search.Solr.SolrIndexRebuilder.<CompleteRebuild>d__10.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Sitecore.Xdb.Collection.Indexing.Rebuild.IndexRebuildFlow.<CompleteRebuild>d__28.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Sitecore.Xdb.Collection.Indexing.Rebuild.IndexRebuildFlow.<RunRebuild>d__25.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Sitecore.Xdb.Collection.Indexing.Rebuild.IndexRebuildFlow.RebuildStatusWatcher.<>c__DisplayClass5_0.<<Start>g__RunRebuildFlowCycle|0>d.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at Sitecore.Xdb.Collection.Indexing.Rebuild.TaskExtension.<ExecuteWithInterval>d__0.MoveNext()

We have already uploaded configs to zookeeper and created xdb collections using the same. Are we missing anything here?

1
  • Can you confirm you created collections called xdb and xdb_rebuild and these are the references in your connection strings? If so, you may have this backwards as they should be the aliases. Dec 9, 2022 at 12:27

1 Answer 1

2
  1. Alias should be suffixed with _internal and not with _mainalias. Make sure your alias are called xdb_internal and xdb_rebuild_internal. You can use any suffix for sitecore and use the same in the configuration but not for xdb.

    Reference this link for more informaion.

  2. You must use xdb and xdb_rebuild in your connection strings, not xdb_internal and xdb_rebuild_internal. xdb and xdb_rebuild are the default names of the primary and secondary indexes. If you change the names of the indexes, you must update all connection strings.

  3. Also, make sure uniqueKey field has value id in xdb schema and not _uniqueid. _uniqueid is for Sitecore indexes whereas for xdb it should be id.

    Example : <uniqueKey>id</uniqueKey>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.