We host the SOLR as an app service in the Azure PaaS. It seems that SOLR runs on the different port every time.

Is there any way to restrict the SOLR to run on a single port only?

  • I think HTTP_PLATFORM_PORT should be used to run Solr on a single port. Check this one getfishtank.com/blog/… Commented Dec 16, 2022 at 8:13
  • Is it Azure IaaS or PaaS? Commented Dec 19, 2022 at 5:34
  • @HimmatSinghDulawat It is PaaS
    – Astle
    Commented Dec 21, 2022 at 11:16
  • @SumitHelaiya I don't see any option to run it on single port in that link
    – Astle
    Commented Dec 21, 2022 at 11:20
  • 1
    web.config screenshot <httpPlatform processPath="%HOME%\site\wwwroot\bin\solr.cmd" arguments="start -p %HTTP_PLATFORM_PORT%" startupTimeLimit="20" startupRetryCount="10" stdoutLogEnabled="true"> try by replacing %HTTP_PLATFORM_PORT% with port number like 8983. Commented Dec 22, 2022 at 1:40

1 Answer 1


As far as I know,Azure app service will dynamically assign ports within the platform.By default, it's not allowed to restrict one specific port only. While you can try some alternative workaround:

  1. Try setting up a rverse proxy using nginx or IIS to make it listen the port and forward the reuqest from solr app.
  2. Try to use a VM instead of Paas Service.You can try to install a stand-alone instance on VM server with more control over network and without restriction on ports. Hope it helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.