1
  • OS: Windows 11 22H2 22621.963
  • Docker version 20.10.21, build baeda1f
  • Docker Desktop 4.15.0 (93002)

I downloaded the 10.3 XC SDK container files. I ran the ComposeInit.ps1 for the xc0 topology without any issues. I pulled all the images without any issues. When I go to run docker-compose up -d I get the following errors:

Error message

For the ComposeInit.ps1 I supplied the following parameters:

-Topology "xc0" -LicenseXmlPath "C:\Sitecore\license.xml" -SitecoreAdminPassword "Password123$" -SqlSaPassword "S1t3c0reL0c4l"

I was able to run XP0 and XP1 without any issues. Does anyone know how to make XC0 work?

UPDATED: Here is a picture of the images pulled. All are showing 10.3-ltsc2019 except the bottom 4 which appear to be the ones erroring. Maybe the XC0 config is setup to pull the wrong images?

enter image description here

3
  • 1
    did you switch to the windows container in docker? docker should show a switch to Linux containers... option - i.stack.imgur.com/lZ8od.png Dec 19, 2022 at 8:24
  • Yes, I am using Windows Containers. I literally deleted the pulled images from my XP0 (working) and did the installation steps for XC0 and it did not work.
    – David D.
    Dec 19, 2022 at 16:22
  • 1
    Are you running process isolation? If so, switch it to hyper-v
    – Mark Cassidy
    Dec 19, 2022 at 16:50

1 Answer 1

0

Apparently, Windows 11 only supports hyper-v isolation for containers at this time. The comment from Mark Cassidy led me to revisit the installation instructions where I found this information on a Microsoft link:

enter image description here

Sitecore, if you are reading this, you should really add a note to your installation instruction to switch isolation mode if using Windows 11. Windows 10 does show support for both hyper-v and process isolation on Windows Server 2019 containers.

1
  • You, and your project team, will generally always be better off using Hyper-V over processs isolation.
    – Mark Cassidy
    Jan 24, 2023 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.