2

I created a facet as per the documentation: https://doc.sitecore.com/xp/en/developers/92/sitecore-experience-manager/facets.html

In the "Field Name" field I tried the field name as in the item's template and also as in the Solr index. Neither worked.

How do I make it show up in the Sitecore Content Search? Are there any additional settings I have to do?

enter image description here

5
  • did you rebuild the indexes after you made the changes? Jan 12, 2023 at 10:11
  • @VladIobagiu yep. Multiple times. No updates
    – iusmar
    Jan 12, 2023 at 12:22
  • 2
    Please make sure the format of Field Name is correct - it should be similar to Solr field name (lowercase and with underscores instead of spaces) but without the field type suffix. For example, if Sitecore field is called "Title", you should specify title instead of title_t. You can also check Search.log for any error or info messages - usually there is a log message if something is wrong with a facet.
    – Anna Gevel
    Jan 12, 2023 at 13:56
  • 1
    @AnnaGevel Actually, that worked. I had to remove the suffix ( + index rebuild ). Thank you.
    – iusmar
    Jan 12, 2023 at 15:12
  • 1
    @iusmar that's great, I'm glad you solved the problem. I've added this as an answer too so that other people can easily find it in future.
    – Anna Gevel
    Jan 12, 2023 at 15:41

1 Answer 1

3

Please make sure the format of Field Name is correct - it should be similar to Solr field name (lowercase and with underscores instead of spaces) but without the field type suffix.

For example, if a text field is called "Title" in Sitecore, you should specify title instead of title_t.

You can also check Search.log for any error or info messages - usually there is a log message if something is wrong with a facet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.