Trying to work through the xmCloud Foundation head - https://github.com/sitecorelabs/xmcloud-foundation-head-staging#deploy-to-xmcloud and install locally using Docker. But getting this error on container build.

Step 6/12 : RUN curl.exe -sS -L -o node.zip https://nodejs.org/dist/v%NODEJS_VERSION%/node-v%NODEJS_VERSION%-win-x64.zip
 ---> Running in 76a734f4d2f7
hcsshim::CreateComputeSystem 76a734f4d2f7a6afe9a59e9b215037eaa70f324a295141e2a228759f787a2d5a: The request is not supported.
ERROR: Service 'nodejs' failed to build : Build failed
D:\PlayArea\xmCloud\xmcloud-foundation-head-staging\up.ps1 : Container build failed, see errors above

Do I need to disable anything specific? I have checked for instances where C:\ is present and changed it to lowercase

  • This issue got resolved after lowercasing the C: and restarting the machine
    – Abhay Dhar
    Commented Jan 19, 2023 at 6:30
  • Didn't work for me ,In what all files have you made changes
    – Manoj
    Commented Feb 9, 2023 at 15:44
  • This is not an answer and should be added as a comment under the question. Please remove this answer. Thanks. Commented Feb 9, 2023 at 16:11

2 Answers 2


This issue is due to firewall settings and network policy settings on your development machine. Couple of things to try:

  • Ensure that the Use Docker Compose V2 option is not checked and Use the WSL 2 based engine is checked in Docker Desktop. enter image description here
  • Bypass some common network issues by setting DNS servers in the Docker engine configuration and switching the buildkit to false
  "dns": [
  "experimental": false,
  "features": {

enter image description here

  • DNS Flush on your development machine: In the command prompt window, type ipconfig /flushdns You should see a message confirming that the DNS Resolver Cache was successfully flushed.

  • If none of the above options works, install nodejs manually as explained here. Run the set up again.


so after executing multiple commands I was able to fix this issue by executing the command ipconfig/flushdns


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.