1

I have setup Sitecore XM 10.2 in Azure PaaS and while connecting with Solr getting the below error.

ManagedPoolThread #1 16:56:31 WARN IsOnline: Test connection has failed with an exception. Type: 'SolrConnectionException', Message: 'The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.'

It works fine when I run the Solr on http and changed the sitecore connection strings to use http version of solr instance.

Already tried to import the certificate in App Service, added a thumbprint to the App Service configuration but no luck.

Seeking some help here, could someone please help me figure out what I am missing?

5
  • When you open the solr on browser, does it say it has a valid certificate? Jan 18, 2023 at 20:41
  • Yes, in browser it works fine. Jan 19, 2023 at 5:41
  • How is Solr hosted? VM or PaaS?
    – Kamil C
    Jan 19, 2023 at 9:20
  • Solr Cloud on a VM Jan 19, 2023 at 9:47
  • Can you please try telnet from Web app to check the connectivity of Solr?
    – Amit Kumar
    Jan 24, 2023 at 23:20

1 Answer 1

1

Few things to check:

  1. Make sure the certificate is trusted. Generate a root certificate which is in Trusted Root Authority section in VM. Create certificate based on this and set it on "Local Machine/My" section.
  2. Check that in solr config that pfx file path exists and pointing to right file. There are also other config changes that needs to be done, you can find them here Solr Enabling SSL

Second option what can be done is also:

  1. Setup Solr running on http
  2. Put VM behind a VNET in Azure so its not accesible publicly
  3. Block all incoming connections in VM except between App Service and VM. That way no one can access it excepts Sitecore. You can also use Private Link and put it on front of VM and connect through that.
2
  • I have checked the point mentioned above, certificate is already in trusted root, imported in App Service but having the same issue Jan 19, 2023 at 14:28
  • Can you post the connection string here? Jan 19, 2023 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.