For as long as I can remember, my rich text editor hasn't worked.

rich text error

At this point I'm not sure whether it's a security issue or a web config issue, but the problem does affect all sites under the same project if that's any help. I am logged in as admin and this is local development. I just tested it in production, and the error does not occur there.

Therefore, my gut tells me that it's some type of a file issue. But any direction is appreciated.

Here's what the log spits out:

5916 12:40:17 ERROR Application error. Exception: System.Web.HttpUnhandledException Message: Exception of type 'System.Web.HttpUnhandledException' was thrown. Source: System.Web at System.Web.UI.Page.HandleError(Exception e) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoin t, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, B oolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest() at System.Web.UI.Page.ProcessRequest(HttpContext context) at ASP.sitecore_shell_controls_rich_text_editor_editorpage_aspx.ProcessReques t(HttpContext context) in c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Tempor ary ASP.NET Files\root\f5fafede\75924706\App_Web_4an5wvrc.3.cs:line 0 at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplica tion.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& compl etedSynchronously)

Nested Exception

Exception: System.NullReferenceException Message: Object reference not set to an instance of an object. Source: Sitecore.Client at Sitecore.Shell.Controls.RichTextEditor.EditorPage.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoin t, Boolean includeStagesAfterAsyncPoint)

5916 12:40:17 ERROR Error Url: http:/site.com/sitecore/shell/Controls/Rich %20Text%20Editor/EditorPage.aspx?da=core&id=%7B04733BD9-54B4-45F2-8661-EF964BCAA 7E6%7D&ed=FIELD98016355&vs&la=en&fld=%7B217FDF39-763D-4E3D-8193-B8929DF02D00%7D& so&di=0&hdl=H98016451&mo&pe=0&fbd=1

In my web.config, I have the default text editor defined as:

<setting name="HtmlEditor.DefaultProfile" value="/sitecore/system/Settings/Html Editor Profiles/Rich Text Default"/>

Which should be the default value.

When I look in the core db content editor, the tree does appear to expand as referenced and the files look as though they are all there (specifically the /sitecore/system/Settings/Html Editor Profiles/Rich Text Default folder).


  • The last error that starts with ERROR Exception in alarm clock event subscriber is not related to your problem. Remove the contents of the SubmitQueue folder under Data and that error will go away. Dec 15, 2016 at 19:37
  • Much appreciated. Your suggestion did work for getting rid of that error. I will update the question to remove that part as it's extraneous to the issue at hand. Dec 15, 2016 at 19:42
  • @DmytroShevchenko post that as an answer ;) Dec 15, 2016 at 21:07
  • @ZacharyKniebel nah, that was a separate error and a separate fix. Dec 16, 2016 at 5:45
  • I have the same error and I've recently upgraded to 8.2. Could you fix it or still an issue?
    – Alireza
    Jan 5, 2017 at 7:03

1 Answer 1


I have compared your rich text editor request with my local setup. It seems the Sitecore path is missing in the request that you have mentioned. Your request:

http:/site.com/sitecore/shell/Controls/Rich %20Text%20Editor/EditorPage.aspx?da=core&id=%7B04733BD9-54B4-45F2-8661-EF964BCAA 7E6%7D&ed=FIELD98016355&vs&la=en&fld=%7B217FDF39-763D-4E3D-8193-B8929DF02D00%7D& so&di=0&hdl=H98016451&mo&pe=0&fbd=

My rich text editor's request captured through Fiddler (notice the path):

  • So the question then is, where could I make that change to make the path correct? Dec 19, 2016 at 19:30
  • Before this, did you try adding the sitecorepath in it manully & tried accessing it ? was it working ? please confirm. Dec 21, 2016 at 7:29
  • 1
    I have this same problem in all environments. Manually placing the path in the query string does not work. I did notice that all RTE fields that do not have the editor specified in the source field are the ones failing. If I put a path to a RTE then it all works just fine. This was always working for us in 8.2 but not in 9.3 for some reason. Solution, fill out the source field with a path to an editor Mar 23, 2022 at 18:58
  • Adding /sitecore/system/Settings/Html Editor Profiles/Rich Text Default path in the source field did it for similar issue I had. This is the answer.
    – D0cNet
    Mar 24, 2022 at 1:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.