2

We are having the following issue. Please let me know if you have come across a similar issue or know of a potential solution.

In Sitecore Content Editor, all search queries works fine if logged in as admin. For non Admin users, we have 3 different scenarios.

  • Experience Editor search works fine.
  • Context search in content editor from right side works fine. enter image description here
  • Content Editor search on left side returns no results

enter image description here

We have content tree restriction for the non admin user but we are searching for terms where the user has access to the content. We have tried with very frequent used words and alphabets also, but no results show up on content editor search.

No errors logged in Sitecore log file, Sitecore search log and 'Solr' log files.

We are running our instance on Sitecore 8.2.

5
  • 1
    Did you check this? stackoverflow.com/questions/72854929/… Feb 13, 2023 at 10:12
  • Hello @SumitBhatia, I can see the solr queries being generated for master index from the logs
    – D J
    Feb 13, 2023 at 11:55
  • Hello @MarekMusielak, Yes. They are on the root content item when trying to search. which gives result on the right context search but not on the left content editor search
    – D J
    Feb 13, 2023 at 11:58
  • 1
    When you compare in search.log query generated for admin and non-admin users, are they the same?
    – Marek Musielak
    Feb 13, 2023 at 13:08
  • @MarekMusielak, Yes. They are exact same
    – D J
    Feb 13, 2023 at 14:03

1 Answer 1

2

As you wrote in your comment, Solr query generated for admin and non-admin users are the same.

I don't expect that you have any customizations for build in checks of security in Solr, so that would mean that for both admin and non-admin, Solr returns same results.

That means that some results are omitted on purpose by Sitecore, while converting Solr search results into what is shown in Content Editor.

The search logic happens in Sitecore.ContentSearch.Client.Pipelines.Search.SearchContentSearchIndex. From what I can see, the only reason why some search results are shown for Admin and hidden for non-admin users is if that non-admin user doesn't have Hidden items checked in VIEW ribbon:

enter image description here

You may want to check that one.

And if that's not the case, I suggest you decompile the class and replace original with your decompiled version and debug it (or debug Sitecore code if possible for you https://subbu.ca/blogs/debug-sitecore-dlls-made-easy-with-in-built-visual-studio-decompiler-and-symbol-generator/ )

3
  • Hello @Marek Thanks for pointing out the "Hidden Items" checkbox. We tried enabling this for the content authors and they are able to view the search results. For Admin obviously this was checked and it stopped working for admin users, when this is un checked. Now I have checked the items and those were not set to be hidden. and this search result behavior is same for all across content tree. Could you provide any more insights how this could happen ?
    – D J
    Feb 15, 2023 at 8:35
  • 1
    Is any of the ancestors hidden? in Appearance section Hidden checkbox? /sitecore or /sitecore/content item or any other ancestor of your items?
    – Marek Musielak
    Feb 15, 2023 at 10:43
  • Thanks Marek, the root /sitecore item was marked as hidden some how and that seems to be the root cause. Thanks for spending time analyzing the specific issue and providing helpful debug information which helped in finding the root cause and fix it. Thanks again.
    – D J
    Feb 15, 2023 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.