0

I deleted all the files from the temp directory (C:\Users\Username\AppData\Local\Temp) as my local instance was loading too slow.
And now the Content Editor doesn't load.

I tried deploying all the files into the instance, restarted the system and loading the CMS in incognito, with no luck.

The Launchpad loads fine though.

ERROR Application error. Exception: System.Web.HttpUnhandledException Message: Exception of type 'System.Web.HttpUnhandledException' was thrown. Source: System.Web at System.Web.UI.Page.HandleError(Exception e) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest() at System.Web.UI.Page.ProcessRequest(HttpContext context) at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step)
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Nested Exception

Exception: System.Reflection.TargetInvocationException Message: Exception has been thrown by the target of an invocation. Source: mscorlib at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at Sitecore.Reflection.ReflectionUtil.InvokeMethod(MethodInfo method, Object[] parameters, Object obj) at Sitecore.Shell.Applications.ContentManager.ContentEditorPage.OnPreRender(EventArgs e) at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Nested Exception

Exception: Sitecore.CodeDom.Compiler.CompilerException Message: Source file 'C:\WINDOWS\TEMP\yizcraub.0.cs' could not be found Source: File: , line 0 at Sitecore.CodeDom.Compiler.CSharpCompiler.AssertResults(String sourceFile, CompilerResults results) at Sitecore.CodeDom.Compiler.CSharpCompiler.Compile(String sourceFile, String code, String assemblyFile, StringCollection referencedAssemblies) at Sitecore.CodeDom.Compiler.CSharpCompiler.Compile(String code, StringCollection referencedAssemblies) at Sitecore.CodeDom.Compiler.CSharpCompiler.SourceToMemory(String code, StringCollection referencedAssemblies) at Sitecore.Web.UI.XmlControls.FolderControlSource.BuildControlAssembly(XmlNode fileNode, String& assemblyKey, String& assemblyFile) at Sitecore.Web.UI.XmlControls.FolderControlSource.GetControlAssembly(String controlName, String& assemblyKey) at Sitecore.Web.UI.XmlControls.FolderControlSource.ResolveType(String controlName, Boolean includeDynamicTypes) at Sitecore.Web.UI.XmlControls.ControlSource.GetControlType(String namespacePrefix, String controlName, String mode, Boolean includeDynamicTypes) at Sitecore.Web.UI.XmlControls.ControlFactory.GetControlType(String controlName, String mode, Boolean includeDynamicTypes) at Sitecore.Web.UI.XmlControls.ControlFactory.GetControl(Control parent, String controlName, String mode, Object[] properties, AllowGenericControl allowGeneric) at Sitecore.Shell.Web.UI.LayoutGridBuilder.BuildDevice(GridPanel grid, LayoutDefinition layout, DeviceItem deviceItem) at Sitecore.Shell.Web.UI.LayoutGridBuilder.BuildGrid(Control parent)
at Sitecore.Shell.Applications.ContentEditor.LayoutField.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.AddedControl(Control control, Int32 index) at Sitecore.Web.UI.Sheer.ClientPage.AddControl(Control parent, Control control, String placeholder) at Sitecore.Shell.Applications.ContentEditor.EditorFormatter.AddEditorControl(Control parent, Control editor, Field field, Boolean hasRibbon, Boolean readOnly, String value) at Sitecore.Shell.Applications.ContentEditor.EditorFormatter.RenderField(Control parent, Field field, Item fieldType, Boolean readOnly, String value)
at Sitecore.Shell.Applications.ContentEditor.EditorFormatter.RenderField(Control parent, Field field, Item fieldType, Boolean readOnly) at Sitecore.Shell.Applications.ContentEditor.EditorFormatter.RenderField(Control parent, Field field, Boolean readOnly) at Sitecore.Shell.Applications.ContentEditor.EditorFormatter.RenderSection(Section section, Control parent, Boolean readOnly) at Sitecore.Shell.Applications.ContentEditor.EditorFormatter.RenderSections(Control parent, Sections sections, Boolean readOnly) at (Object , Object ) at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain, Boolean failIfNotExists)
at Sitecore.Pipelines.DefaultCorePipelineManager.Run(String pipelineName, PipelineArgs args, String pipelineDomain) at Sitecore.Shell.Applications.ContentManager.Editor.Render(RenderContentEditorArgs args, Control parent) at Sitecore.Shell.Applications.ContentManager.ContentEditorForm.RenderEditor(Item item, Item root, Control editorsContainer, Boolean showEditor) at Sitecore.Shell.Applications.ContentManager.ContentEditorForm.UpdateEditor(Item folder, Item root, Boolean showEditor) at Sitecore.Shell.Applications.ContentManager.ContentEditorForm.Update() at Sitecore.Shell.Applications.ContentManager.ContentEditorForm.OnPreRendered(EventArgs e)

enter image description here

4
  • Does your application have the AppIdentity and IIS User permission? Feb 21, 2023 at 11:33
  • Try to provide apppool permission on website folder. Feb 21, 2023 at 12:30
  • @GauravAgarwal But this is an existing site which was working fine. Is this step still needed?
    – sukesh
    Feb 21, 2023 at 12:41
  • @Qwerty edit your question with stack trace as text
    – Marek Musielak
    Feb 21, 2023 at 13:08

1 Answer 1

-2

This resolved the issue for me.

In IIS Manager, select the Application for your site.

In Advanced settings", change the Identity`.

In my case, it was "Built-in account" which was set to "ApplicationPoolIdentity".

I changed it to "LocalSystem", recycled the app pool and now the Content Editor loads fine.

Changing it back to "ApplicationPoolIdentity", resulted in the same error again. So I left it with "LocalSystem".

enter image description here

2
  • You need to provide apt permission instead of using this. If you have another instance running, you can compare and provide the same permission. This should ideally be the last option in my view. Feb 21, 2023 at 11:38
  • @SumitUpadhyay You could be right. But as I mentioned, when I change it back to "ApplicationPoolIdentity", it gives the same error. I need to try it after a system restart.
    – sukesh
    Feb 21, 2023 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.