1

I am using Sitecore 10.2 with SXA and I am using sitecore_sxa_web_index index. I have multiple articles which I am indexing. I am facing below issue:

  1. Suppose I have 10 articles and when I manually do publish (republish) then in Solr it shows 10 articles.
  2. When I do publish article as a Smart publish then it shows 3 article only.
  3. When I rebuild indexes from control panel then it shows 3 articles only.

Below is my publishing strategy:

<strategies hint="list:AddStrategy">
  <strategy ref="contentSearch/indexConfigurations/indexUpdateStrategies/onPublishEndAsync" />
</strategies>
1
  • 1
    Comments have been moved to chat; please do not continue the discussion here. Before posting a comment below this one, please review the purposes of comments. Comments that do not request clarification or suggest improvements usually belong as an answer, on Sitecore Meta, or in Sitecore Chat. Comments continuing discussion may be removed.
    – Richard Seal
    Feb 28, 2023 at 18:00

1 Answer 1

6

This issue may be coming because while you are doing indexing from the control panel, it is throwing some errors and because of the error it is not indexing all articles.

I would suggest you check the Crawling.log log files and check if there is any error related to indexing.

1
  • Thanks Swati, I found error in Crawling.log, one field was creating problem. Now it's working fine Mar 1, 2023 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.