2

Analysis: After searching on Stack Exchange, I did not find the solution. I went through Import process fails : "Unexpected response from import service: Status message: Found" and Unexpected response from import service: Status message: Found that were near my issue. But the solution provided there will not work in my situation.

Problem: I have installed JSS in disconnected mode, and it works perfectly fine. Now I was trying to install the Sitecore(10.1) JSS in connected mode.

enter image description here

My DNS provided in configuration is working as shown below:

enter image description here

But the import URL is giving a 404, as shown below:

enter image description here

Thanks in advance.

2
  • is reactdemo.dev.local your react application or your CM?
    – Richard Seal
    Mar 16, 2023 at 18:49
  • 400 bad request. One of response could be absence or incorrect api key. Can you double check that your configuration was deployed? (Did you deploy it using jss deploy config command line?)
    – Anton
    Mar 16, 2023 at 21:55

1 Answer 1

1

Thank you for your responses, @Richard Seal and @Anton.

But, I was ultimately able to understand it after hours of effort. The answer is really quite easy. This step was not mentioned in any installation videos or blogs that I read. After using the jss setup command and completing the setup, the following information is returned.

enter image description here

It states,

  1. Ensure Host name in few place.
  2. Deploy your configuration.
  3. Deploy your app.
  4. Test your app.

I omitted step two (Deploy your configuration). I was therefore receiving an error.

I'm hoping that this will be useful to others.

1
  • hehe, so actually, I guessed!
    – Anton
    Mar 17, 2023 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.