1

We are using Sitecore-10.3/Headless/SXA/NextJS.

Trying to add a new custom SXA headless module to my headless-SXA website but the newly created module is not showing up.

Steps to reproduce

  1. Create a new module using the "Add module" option in /sitecore/system/Settings/Feature.

enter image description here

  1. Post this include some renderings by the options add/clone rendering as per your wish.

  2. Now try to add this new custom module to your headless-SXA site. Using the script "Add site module".

enter image description here

  1. Expectation is to show the newly created custom headless module but this is not showing the new custom headless module.

enter image description here

1 Answer 1

2

This issue is happening because of your custom module site setup root is using a template from "Experience Accelerator", instead of "JSS Experience Accelerator". Follow the steps to fix this

  1. Go to your modules, where you created them. In my case /sitecore/system/Settings/Feature/YourSite/CustomModule/Headless CustomModule Site Setup.

  2. Check the template used. It pointing the legendary "Experience Accelerator". enter image description here

  3. This should be corrected. Configure => Change your template like below, enter image description here

  4. Now try to install module to your headless-SXA website. It will show your custom module.

Note: This issue is applicable for Tenant setup as well. You should change this template in your module /sitecore/system/Settings/Feature/OMNIA/Headless Experience Accelerator/HeroBanner/HeroBanner Tenant Setup

1
  • 2
    Thanks @Andi AR, I was facing the same issue. and that solution worked for me!!
    – Gautam
    Commented May 4, 2023 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.