I'm trying to install the Graphical setup package for XP Single (Sitecore 10.1 Update 2) on a new laptop which has Windows 11 Pro with SQL Server 2022 16.0.1050.

This is the error during the installation:

enter image description here

Sitecore support has informed that:

Sitecore 10.1 is not compatible with Windows 11 and have never been tested with Windows 11

Unfortunately, I do not have access to another machine with Windows 10.

Added the "TrustServerCertificate": true following this post, but it's the same error.

Is it possible to disable the security SSL check in the Operating system or any other way/hack to complete the installation.

We have 10.1.2 in PRD and that is why I wanted to have the same version on my local machine.


2 Answers 2


Not sure it will solve your issue but you can also try disabling the TLS 1.3 from your entire system. To do this you need to run the below Powershell script.

New-Item `
   'HKLM:\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.3\Server' `
   -Force | Out-Null
New-ItemProperty `
   -path 'HKLM:\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.3\Server' `
   -name 'Enabled' -value '0' -PropertyType 'DWord' -Force | Out-Null
New-ItemProperty `
   -path 'HKLM:\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.3\Server' `
   -name 'DisabledByDefault' -value 1 -PropertyType 'DWord' -Force | Out-Null

Try this and see if it works for you.

Another thing you can also try adding a few parameters to your connection string like encrypt=false. To do this if you open your installation folder, there is a file called spe.json. You can see that under "Variables" it is trying to create the connection string. Try adding the values. Not sure if it will work but you can try.

  • This did not work. How can I enable TLS again?
    – sukesh
    Commented Apr 14, 2023 at 11:51
  • 1
    Go to the Registry Editor and open the path given in the script above and enable it. Here HKLM means HKEY_LOCAL_MACHINE also refer to this for more details. asustor.com/en-gb/knowledge/detail/?id=&group_id=1011 Commented Apr 14, 2023 at 12:26

You can give it a try below solutions if that resolves your problem. As per the Microsoft SQL troubleshooting page (Link).

There are 2 more solutions:

  1. Use Microsoft OLE DB Driver for SQL Server 18.x. You can download the driver from Release notes for the Microsoft OLE DB Driver for SQL Server.

  2. If the application connection string property already specifies a value of Yes or Mandatory for the Encrypt/Use Encryption for Data setting, change the value to No or Optional. For example, Use Encryption for Data=Optional. If the connection string doesn't specify any value for Encrypt/Use Encryption for Data, add Use Encryption for Data=Optional to the connection string. For more information, see Encryption and certificate validation.

The change must be done as explained in this article by adding "Encrypt": "Optional" to 4 instances of Invoke-SqlCmd in xConnect-xp0.json:


Hope it helps!

  • Could you please tell me where can I find this conn string in the installation package
    – sukesh
    Commented Apr 14, 2023 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.