I have installed 10.3 on my Windows 11 Pro machine by running the PowerShell script - XP0-SingleDeveloper.ps1.

However, that doesn't install SXA.
So, I had to install separate packages for SXA & PowerShell Extensions.

I can now see the options to create Tenant & Tenant Folder in CMS.
But when rebuilding indexes, the sxa indexes are not listed.
I was looking for myinstance_sxa_master_index & myinstance_sxa_web_index.

When I open the Solr portal (8.11.2), even there, these are not listed.

  1. Is this expected?
  2. Do I really need these indexes?
  3. If yes, what additional steps should I perform to get them?

2 Answers 2


It's not uncommon for SXA indexes to not appear after installation, even if you have installed SXA separately. This is because the SXA indexes are not created by default when you install Sitecore.

To create your SOLR SXA core:

  1. Navigate to your Solr folder (<path_to_solr>\server\solr) and Duplicate the core directory created for sitecore_master_index (or company_name_master_index) twice and rename it to:



  1. In those two folders, remove everything except the conf directory.
  2. On the Solr web interface, click Core Admin, and click Add Core to add sitecore_sxa_master_index. Do the same for sitecore_sxa_web_index.

Make sure that the names of the Solr cores you created match the settings for sitecore_sxa_master_index and sitecore_sxa_web_index in Sitecore.XA.Foundation.Search.Solr.config. If you have to rename the cores > you have also to change the id’s in in > Sitecore.XA.Foundation.Search.Solr.config

enter image description here

  1. In Sitecore, log in to the Launchpad, and open the Control Panel.
  2. In the Indexing section, click Populate Solr Managed Schema.
  3. In the Schema Populate dialog, select sitecore_sxa_master_index and sitecore_sxa_web_index, and click Populate.
  4. In the Indexing section, click Indexing Manager.
  5. In the Indexing Manager dialog box, select sitecore_sxa_master_index and sitecore_sxa_web_index, and click Rebuild.

The reason for creating the cores in SXA is to enable its functionalities to work properly. Failure to create these cores will result in exceptions being thrown when attempting to use SXA or SXA-related functionalities. Therefore, it is necessary to create the cores in order to ensure the smooth functioning of SXA.

  • Even after creating the Solr folders and the cores in solr folder with the name sitecore_sxa_master_index, I still do not see it listed in CMS indexing dialog. I have also logged out & in. The name of the id in the config is the same - sitecore_sxa_master_index.
    – sukesh
    Commented Apr 22, 2023 at 9:18
  • 1
    you need to restart solr service and do the IIS reset. Commented Apr 22, 2023 at 9:19
  1. When you install with a SXA module normally it creates a sitecore_sxa_master_index and sitecore_sxa_web_index. Patch you can find out at wwebroot\YourInstanceFolder\App_Config\Modules\SXA\z.Foundation.Overrides\Sitecore.XA.Foundation.Search.Solr.config and respective Solr folders/configurations are created too.
  2. Yes, It required the indexes to be there to perform the SXA in the desired way. If you don't have the index it could impact the functionality like search and performance as well as general exceptions.
  3. You need to configure SXA indexing. Refer to the official link to Configure SXA indexing. Configure SXA indexing

Or another easy way to create sxa cors is by using Sifon by Martin Miles.


Hope it helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.