2

I'm getting the following error when trying to get my local XM up and running per this article:

https://doc.sitecore.com/xmc/en/developers/xm-cloud/walkthrough--setting-up-your-full-stack-xm-cloud-local-development-environment.html

Error:

Invoke-RestMethod : Unable to connect to the remote server
At C:\DEV\XM-Cloud-Introduction\up.ps1:95 char:23
+ ...   $status = Invoke-RestMethod "http://localhost:8079/api/http/routers ...

Any ideas on how to resolve this problem?
NOTE: I had everything working just fine the last time I ran ./up.ps1 about a month ago.

1
  • Have you tried running down.ps1 and then up.ps1 again? It seems to be an issue with traefik. I would see my docker to check if traefik is coming up without any issues. Jul 26, 2023 at 8:14

3 Answers 3

1

Apart from the resolution provided my others you may also try listing the network used-

docker network ls

And prune-

docker network prune

Fo me this resolved the issue and was able to porceed.

0

Docker does not remove unused resources automatically. Unnecessary resources can therefore accumulate over time and use up disk space.

Resolution 1: I did encounter this with container setup and It was due to a lack of free disk space. Clear disk space, use the docker system prune -a to remove unused Docker images.

This command removes:

  1. All stopped containers.
  2. All networks are not used by at least one container.
  3. All dangling images (not tagged and not referenced by any container).
  4. All build caches.

-a (or --all) - Removes all images without at least one container associated with them.

Reference: https://doc.sitecore.com/xp/en/developers/101/developer-tools/sitecore-docker-cheat-sheet.html

Resolution 2: Although my machine had .NET Core SDK versions 3.1 and .NET SDK 5.0 (installed as part of VS 2019) the above error occurred, .Net SDK 6.0 is needed to resolve the error. In other words, after the install you must be able to see the 6.0.xxx folder as in scr shot below:

enter image description here

Reference: https://navansitecorenotes.blogspot.com/2022/01/another-cause-for-generic-sitecore.html

Hope it helps!

0

I ended up running down.ps1 and up.ps1 a couple of cycles and everything magically started working. I haven't had time to figure out the root cause.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.