0

when adding contact manually in list manager in sitecore 10.2 not show the contacts , i tried rebuild all indexes and the same result enter image description here

2
  • did you rebuild xdb index? the contacts are indexed in the xdb index and this kind of error appear when xConnect services are not up and running. did you check logs from xConnect ? May 19, 2023 at 5:27
  • Either the new facet with contact list information on a contact is not saved properly in xconnect or index is not updated propely. Check your xconnect services and xdb index.
    – Marek Musielak
    May 19, 2023 at 6:18

1 Answer 1

1

PS: I am not having access to the comment, so adding it as an answer. Hope this is helpful.

  1. Contact information is stored in the xdb collection database. You can check the data in the ContactFacets table. Example: [sc102_Xdb.Collection.Shard1].[xdb_collection].[ContactFacets]. If the contact is properly saved, you may find three records with FacetKey such as Emails, ListSubscriptions (contains subscribed contact list details), and Personal (contains personal information).

  2. Also check the xdb index is updated and having latest entries. Solr portal > select {scinstance_xdb}. Try reloading the Solr core or restarting the Solr services. Solr portal - Statistics of the core

  3. You can also checkout the answer to the similar question for Sitecore 9 here: contact added manually not appeared in contact list in list manager sitecore 10.2 and see https://doc.sitecore.com/xp/en/developers/102/sitecore-experience-platform/rebuild-the-xdb-index-in-solr.html for more information on rebuilding the xdb index.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.