1

Sitecore Forms are not showing in the Forms application from launchpad. I tried rebuilding my project forms folder from the developer menu but getting the below error

the current item and its descendants can not be indexed.

I have tried checking logs but I am not seeing any error in logs.

5
  • you need to build Sitecore_web_index, master index, marketing indexs from control pane; Commented May 23, 2023 at 13:15
  • Did you try indexing the indexes from the control panel? Commented May 23, 2023 at 13:45
  • i tried indexing from control panel still forms in one specific folder not getting indexed. and not showing
    – kartik
    Commented May 23, 2023 at 13:57
  • You mean all the forms are not showing or any specific one is creating the issue? @kartik Commented May 23, 2023 at 14:07
  • only forms in one specific folder are not getting indexed. I have 7 folders for different languages forms. facing issue with one folder forms only.
    – kartik
    Commented May 23, 2023 at 14:12

3 Answers 3

3

I had face same issue in past, you have to rebuild your master and web indexes, then form will start showing in form application.

Hope this helps you.

1

Sitecore forms might not be visible if IsTemplate or Hidden system fields are not included in the search index. Such a scenario is possible if indexAllFields is set to false or the fields are excluded from indexing explicitly using the configuration section with the list:AddExcludedField hint.

To resolve the issue, consider the following steps:

  • Download the Sitecore.Support.229445.config file and copy it to the \App_Config\Include\zzz folder.
  • Rebuild the sitecore_master_index.

Refer to this article to download the configs.

https://support.sitecore.com/kb?id=kb_article_view&sysparm_article=KB0471482#:~:text=Description,with%20the%20list%3AAddExcludedField%20hint.

Hope this will work for you.

1
  • I tried this even rebuild the indexes again but still not showing in Forms application. ALso I am getting this issue for korea language forms only.
    – kartik
    Commented May 23, 2023 at 17:13
0

The forms are displayed on Dashboard using the Search indexes in background, so you need to rebuild our Search indexes from Control Panel to display the newly created form.

  1. Go to Control Panel from the Launchpad

  2. Click on Indexing Manager.

    enter image description here

  3. Unselected all the indexes and Select only the highlighted in below image. enter image description here

  4. Click Rebuild.

  5. Once the indexes are successfully built, go to Sitecore Forms from Launchpad.

  6. You should be able to see the newly created form on the Dashboard.

Hope it helps!

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.