1
  • I have installed the plain Sitecore 10.3 XP in my local.
  • Installed the Sitecore headless rendering 21.0.1 package from this URL https://dev.sitecore.net/Downloads/Sitecore_Headless_Rendering/21x/Sitecore_Headless_Rendering_2101.aspx
  • Created the API key and verified the service https://sc103-sc/sitecore/api/layout/render/jss?item=/&sc_apikey={03E4BE22-4625-4612-98B4-C735C5131B23} it's worked.
  • Followed the steps to setup the first JSS application in my local and after I tried to deploy the application to Sitecore path with the command jss deploy app -- includeContent --includeDictionary

It got failed and received the error in the command prompt as below :

enter image description here

received the error in log file as below

Exception: System.Web.HttpException
Message: A public action method 'Import' was not found on controller 'Sitecore.JavaScriptServices.AppServices.ImportService.Controllers.JssImportHostController'.
Source: System.Web.Mvc

When I access the import URL in browser, receive the error as below

enter image description here

From this thread Unexpected response from import service: Status message: Found, I found the below :

Make sure you have installed the JSS Server Components Sitecore package through installation wizard as per your Sitecore instance version from following link. https://dev.sitecore.net/Downloads/Sitecore_JavaScript_Services.aspx

Do I need to add the package "Sitecore JavaScript Services 15.0.1" also? from https://dev.sitecore.net/Downloads/Sitecore_JavaScript_Services/150/Sitecore_JavaScript_Services_1501.aspx or installing the package "Sitecore headless rendering 21.0.1" is enough ?

I tried to install the Sitecore JavaScript Services 15.0.1 on top of it. Installation got failed, earlier, I have been asked to overwrite few config files related to JSS. Finally my Sitecore instance got broken and throwing the following error now.

enter image description here

Can anyone help me for the JSS application development and deployment do i need both (Sitecore Headless Rendering 21.0.1 and Sitecore JavaScript Services 15.0.1) the package installed in my vanilla Sitecore version ?

What could be the reason for failing with Import Service?

3
  • 1
    Which package from link you have installed? XP or XM one. Can you please update your question? You don;t need to install Sitecore Javascript Services 15, Headless Rendering is enough for Sitecore 10.3 as Javascript Services were renamed in Sitecore 10.1 May 25, 2023 at 8:43
  • What versions of npm jss packages do you use in your FE project? Can you please share your packages.json? May 25, 2023 at 9:00
  • I have updated the question with my packages.json. I have sitecore 10.3 XP standalone sitecore + Sitecore Headless Rendering 21.0.1 (Sitecore Headless Services for Sitecore XP)
    – Jey
    May 25, 2023 at 12:19

2 Answers 2

1

I have fixed the issue. When I create a JSS app, I was providing my Sitecore hostname, which caused redirecting round robin and throwing error. My understanding is, I can provide the Sitecore host name in one place where I am supposed to provide the Sitecore hostname.

2
  • Hello, I am having a similar issue. I am not clear on what host name i should provide. When it asks for sitecore host name, do I provide the host name to my sitecore instance? Or the host name for the app I am creating? Sep 21, 2023 at 16:18
  • Host name is your JSS app host name which you provide in host file and binding.
    – Jey
    Sep 25, 2023 at 12:49
0

I had same issue during installation, after some investigation I found that I was using an incorrect entry for the Sitecore hostname. When I corrected it so that it mapped to the path to the Sitecore folder, that resolved this issue.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.