3

I'm trying to setup a uCommerce for Sitecore for the first time. But I'm getting a NullReferenceException - so I suspect I've done something wrong, or am missing an installation step.

What I did was: I've installed a fresh Sitecore 8.1 installation, then installed uCommerce (7.3.1.1634) developer license as a package via Sitecore Instance Manager. (I've also tried installing the package myself)

Navigating into the administration interface --> Commerce Settings (uCommerce).

I expand the Stores node, uCommerce.dk node, and go to the uCommerce node in the default installation content

Now, if I try to fill out the display name in the English tab, and save my ProductCatalog I get:

[NullReferenceException: Object reference not set to an instance of an object.]
   UCommerce.EntitiesV2.Factories.ProductCatalogFactory.AddDefaults(ProductCatalog productCatalog, ProductCatalogGroup productCatalogGroup) +131
   UCommerce.Presentation.Presenters.Catalog.EditProductCatalogPresenter.View_Save(Object sender, EntityCommandEventArgs`1 e) +703
   UCommerce.Web.UI.Catalog.EditProductCatalog.OnSave(Object sender, EventArgs e) +124
   System.Web.UI.WebControls.ImageButton.OnClick(ImageClickEventArgs e) +143
   System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument) +185
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1734

I've tried to publish the site and rebuild indexes, but it didn't fix the issue.

I've also tried to create my own ProductCatalog and my own Store in various combinations; and that goes well. But if I try to update the name of my ProductCatalog, I get the same exception.

(the uCommerce Admin interface to illustrate) enter image description here

EDIT: For some reason it looks like the admin page does not get the QueryString value it requires, but it doesn't fail on the demo site, so it looks like possible the demo build does not match the developer license version.

1 Answer 1

1

According to feedback from uCommerce forum, this seem to be a known bug which will be fixed in a release January '17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.