1

We are facing the below issue with Sitecore 9.3 where the Target dropdown is blank for non admin users and it has the correct 3 values for the content authors where Administrator checkbox is checked. We have tried the below but with out success.

The only thing that worked for me is commenting the following line in Sitecore.Speak.Applications.config

But the Adding Email to the link option is missing in the "internal link.aspx" so due to business restrictions, we could not use the other dialog.
<override dialogUrl="/sitecore/shell/Applications/Dialogs/Internal%20link.aspx" with="/sitecore/client/applications/dialogs/InsertLinkViaTreeDialog" />

Please suggest.

1 Answer 1

2

If it works correctly for your Administrators, then items should already be in the core index.

As the issue you described is only happening for non-admin users, I suspect that the problem is in Sitecore access permissions. Please try switching to the Core database and going to the folder /sitecore/client/Applications/Dialogs/InsertLinkViaTreeDialog/PageSettings/Targets. Then check "Security Details" of the folder and its child items. By default this folder does not have any specific security rules and access to it is allowed to all users with the role sitecore\Sitecore Client Users.

You can also use the Access Viewer tool to see the final access rights for any user or role.

Security details

The reason why it starts working when you comment out the <override> line in the config is because it tells Sitecore to switch to the older version of the dialogue where all "Target" dropdown options are hardcoded and, therefore, they are the same for all users including Administrators.

12
  • 1
    Hello Anna, Thanks for checking the issue and providing the detailed explanation. But we have already verified the security access rights for the folder "/sitecore/client/Applications/Dialogs/InsertLinkViaTreeDialog/PageSettings/Targets" and I have even created a dummy user and have provided read write access to this folder with subitems. Still the options are not showing up for the user, we have tried this with multiple users by updating the security rights for user and role basis.
    – D J
    Commented Jun 14, 2023 at 10:20
  • 1
    That's interesting, please could you check if you see a request to /-/item/v1/sitecore/shell?search=&searchConfig=%7BABF3B317-CFCA-441A-815A-F810AB1EDB0D%7D&sc_content=core&language=en&payload=full in the browser Network tab when you open the "Insert Link" dialogue? If yes, what is in the query string and response for this request? It should return 3 items for the "Targets" dropdown. And if you do not see this request, are there any JavaScript errors in the browser console?
    – Anna Gevel
    Commented Jun 14, 2023 at 11:44
  • 1
    I have verified this in network tab, the request is visible on network tab for both admins and non-admins. For Admins, the response has totalcount:3, resultCount:3 and the complete response. For Non admins, totalCount is 3, resultCount:0 and items array is blank.
    – D J
    Commented Jun 14, 2023 at 13:41
  • 1
    Yes the Request url is exact same. The same query returns result when logged in as admin and no results when logged in as non admin user. The issue has to be related to security access but I could not find any special security rights for the folder or child items for "/sitecore/client/Applications/Dialogs/InsertLinkViaTreeDialog/PageSettings/Targets".
    – D J
    Commented Jun 15, 2023 at 7:40
  • 1
    Please could you try the following: 1. Go to the Access Viewer in Sitecore (you can add the parameter ?sc_content=core to the URL to switch to the core DB). 2. Select one of the non-admin users at the top. 3. Navigate in the tree to one of the child items of /sitecore/client/Applications/Dialogs/InsertLinkViaTreeDialog/PageSettings/Targets. 4. Select the Read access rule and screenshot the details that appear on the right. This is how it looks on my Sitecore instance imgur.com/XqXH22C, how does it look on your website?
    – Anna Gevel
    Commented Jun 15, 2023 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.