10

I am getting this error when trying to access a Sitecore website. Here's a screenshot of the complete error message.

enter image description here

It probably has to do with configuring Solr to work with Sitecore. Does anyone have any idea what the source of the problem might be?

7

I'm not sure what version of Sitecore you are using but have you checked the following steps?

  1. All Lucene config files (Sitecore.ContentSearch.Lucene.*) have been renamed to .disabled in wwwroot\\App_Config\Include.
  2. All Solr configs are enabled, those that follow this pattern: Sitecore.ContentSearch.Solr.* (there is a good script for this here: https://gist.github.com/patrickperrone/59b8745ee8b8ff9045b5)
  3. You have set the value of ContentSearch.Solr.ServiceBaseAddress and ContentSearch.Provider is set to "Solr".
  4. You have set the Solr processor to "Sitecore.ContentSearch.SolrProvider.CastleWindsorIntegration.WindsorInitializeSolrProvider" here: Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config.
  5. Rebuild your indexes
  6. Check your custom indexes and custom search index configuration

More info here: https://doc.sitecore.net/sitecore_experience_platform/setting_up__maintaining/search_and_indexing/walkthrough_setting_up_solr#_Configuring_Sitecore_to

This is also a bit out of date for the latest version of Sitecore but is a nice walk-through:

https://born4joy.wordpress.com/2015/09/03/installation-and-configuration-of-solr-for-sitecore-8/

One other thing worth checking is how you are configuring your IOC for Solr, it can be done like so in the Global.asax:

<%@ Application Language=’C#’ Inherits=”Sitecore.ContentSearch.SolrProvider.CastleWindsorIntegration.WindsorApplication” %>

In our 8.1 site We are doing this via WebActivatorEx instead but it does the same thing.

  • Thanks for the info man. Step 4 is the one I missed. The problem is that my Sitecore.ContentSearch.Solr.DefaultIndexConfiguration.config file doesn't have the <initialize> pipeline where I can set the Solr processor. I tried adding it but that doesn't solve the problem. – andrei Dec 22 '16 at 19:00
4

I have faced same issue and resolved by disabled all lucene indexes and enabling all solr indexed.

Please dont go by filename to disable the indexes. first enable lucene and go to index manager and note down all index names then disable.

In my case, I have missed mediaframework_brightcove index because it doesn't have name with lucene.

Enable all Solr indexes.

  • 2
    Thanks for your input. In my case, the Sitecore.MediaFramework.config file was the one that was causing issues. Disabling that got rid of the error. – andrei Feb 1 '17 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.