6

I have changed update strategy for Master database to be "manual" rather than "sync", which to my understanding should not update "master" when data changes in master database. I can see in crawling log that strategy is initiated properly:

[Index=sitecore_master_index] Initializing ManualStrategy. Index will have to be rebuilt manually

However, I can see in the logs the following:

Starting update of index for the database 'master' (6 pending). Update of index for the database 'master' done.

Am I missing something or that's something normal?

3

You are mixing a Content Search index (which indeed you have disabled) with legacy Sitecore.Search database indexes which apparently are still working.

In order to disable Sitecore Legacy indexes you should set the following setting values:

<setting name="Indexing.UpdateInterval" value="00:00:00"/>
<setting name="Indexing.Enabled" value="false" />

Also you have to remove <indexes> definitions for each <database> definition.

It can be done by removing master and core nodes from index locations under the /configuration/sitecore/search/configuration/indexes/index/locations node in the Sitecore.config

2

i have changed my local instance's master index strategy & even i see similar logs INFO HttpModule is being initialized ManagedPoolThread INFO Starting update of index for the database 'master' (3 pending). ManagedPoolThread INFO Update of index for the database 'master' done.

But i went ahead & tried to search the recently added item from content editor, the item didnt turn up :) i probably think thats the normal behaviour & doesnt mean that indexing is actually done for the item that has been added recently. Sitecore by default logs an entry that it processed the strategy that has been configured & doesnt actually indexed the item :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.