6

I'm trying to install SIM 14. 160526 Update-3. When I run the wizard it gets to the "File System Permissions" screen and it says "Make sure the NETWORK SERVICE user account has full access to the following folder: c:\inetpub\wwwroot"

NETWORK SERVICE does have Full access to c:\inetpub\wwwroot but when I click on "Next" it says I probably don't have proper permissions set and to click on "Grant". When I click on "Grant" two popups appear. One says "Applying security changes" and has a progress bar and another says "Permissions were successfully set". It's weird that they both come up at exactly the same time. If I click OK on the "Permissions were successfully set" dialog box, the two dialogs disappear but then when I'm back where I started. I click "Next" I get the same message that I probably don't have proper permissions set etc.

Does anybody know how to resolve this? I have Sitecore 8.2 and I have a two-VM server setup. One with SQL Server 2014 on which I installed sitecore DB and another VM for the sitecore website. I am installing SIM on the sitecore website VM. I saw some posts where it said this is really a SQL Server permissions problem. The connection string the wizard is picking up is correct and I tried running SQL Server logged on as NETWORK SERVICE, Local Service and the Domain Administrator account but none made any difference.

I'd really appreciate any help with this!

2

Since you are installing this on two separate VMs you have two options.

1) If the VMs are in the same domain, you must grant the NetworkService of the computer running SIM access the VMs and run the MSSQLSERVER Service as NetworkService on the computer running SIM. I do not recommend this because you are giving a system account access across servers.

2) The better solution is to change the permissions that the website and SQL are running under. To do this, you will need to change it under Advanced Settings under SIM. Sitecore SIM Configuration

Select Advanced Settings Under Advanced Settings, you can configure several options. Take a look at "Core/Install/WebServer/Identity" Sitecore SIM Advanced Configuration

You can read more on advanced configuration of SIM here https://github.com/sitecore/sitecore-instance-manager/wiki/Advanced

0

Instead of using "Grant" button, please give manual permission to the folder "c:\inetpub\wwwroot". If you have already tried this then try mapping instances root folder (in SIM settings) to a different location.

0

Had the same issue while installing SIM on vm. Make sure that you run installer with administrator privileges and your user has the permission to do so

0

SIM doesn't​ support distributed installations as far as i'm aware. It has to find SQL Server running in the same machine in order to be able to attach the databases. The message is confusing but it is not necessary about rights on that folder as seems to be your case, but rights on SQL

0

Try this: Change SQL Server service setting to login as the Network Service and re-start the service. enter image description here

Click the Grant button again on installation wizard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.