4

The messages are warning... but i cannot get the endpoints... any ideas ?

level=warning msg="The \"H\" variable is not set. Defaulting to a blank string."
At line:1 char:1
+ docker-compose up -d
+ ~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (time="2023-07-1... blank string.":String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
 
level=warning msg="The \"H\" variable is not set. Defaulting to a blank string."
level=warning msg="The \"H\" variable is not set. Defaulting to a blank string."
level=warning msg="a network with name tac_default exists but was not created by compose.\nSet `external: true` to use an existing 
network"
network tac_default was found but has incorrect label com.docker.compose.network set to ""

enter image description here

3
  • Can you add the error in the text along with the image? Commented Jul 10, 2023 at 14:14
  • Hi , i added additional information. thanks
    – luckymow8
    Commented Jul 10, 2023 at 14:44
  • Are you able to share some of your .env file and remove sensitive information? Is it possible you are using quotes in there where perhaps you shouldnt? Commented Jul 10, 2023 at 14:48

1 Answer 1

7

You may encounter a similar issue when the container is spun up using the up.ps1 script, and subsequently, when attempting to run docker compose down followed by docker compose up, you encounter an error. This issue is likely caused by the network interface created by up.ps1 not being properly utilized during the execution of docker compose up.

To resolve this problem, follow these steps:

  1. Run docker network ls to list all the available networks.
  2. Run docker network prune to remove all networks. Note: This command will delete all unused networks on your system.
  3. If you want to remove specific network use the command docker network rm <network Id> <space> <network Id> to remove the problematic network.
  4. Once the network pruning is complete, run docker compose up -d to start the containers.

After following these steps, the issue should be resolved, and docker compose up should work fine.

Reference:

  1. https://docs.docker.com/engine/reference/commandline/network_prune/
  2. https://docs.docker.com/engine/reference/commandline/network_ls/
1
  • 1
    This solved the error for me, thank you! Commented Dec 4, 2023 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.