Anyone getting problems following the Getting Started template? Tried 2 different installations and still getting errors.


Some of the errors I am getting:

Error #1: level=warning msg="The \"R\" variable is not set. Defaulting to a blank string. enter image description here

Error #2: docker-compose : failed to solve: failed to compute cache key: failed to calculate checksum of ref 3f3de231-5630-4e0d-9880-af4d75348d87::bxasqp1metajlwinwtmzknhdf: "/C:\\module\\db": not found enter image description here

  • Could you attempt executing init.ps1 once more and check if you encounter the same error? Commented Jul 17, 2023 at 14:21

3 Answers 3


Double check that you did a "switch to Windows containers" from the Docker Desktop system tray. If you have the option to "Switch to Windows Containers" instead of "Switch to Linux containers" as a choice then this is probably the cause of at least Problem #2..

enter image description here


This looks very similar to what I faced after upgrading Docker Desktop and changing compose syntax to V2.

  • Error#1 - You can search for an environment variable with "R" in it's value and remove escape characters.
  • Error#2 - You can locate that volume in docker-compose file and add
    "\" at the end.

Make these 2 changes and try running up.ps1 again.

Here is a blog for reference - https://blogs.perficient.com/2023/07/03/migrating-docker-compose-from-v1-to-v2-code-details/


These errors occur when complex string values are present in .env files which are not wrapped in string literals.

For example:


The solution is to wrap all of your complex values like so:


Check out this pull request for more info. I would encourage anyone reading this to submit similar PRs wherever you spot similar issues!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.