1

We have upgraded Sitecore 9.3 to Sitecore 10.3 version. But after upgrade we are getting the Circular templates error for multiple templates. We have verified each and every templates's fields, inheritance,other section but we are not getting any clue.

ERRORS are

3280 08:10:27 ERROR Template trail: System/Templates/Sections/Tasks : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : System/Templates/Sections/Advanced : System/Templates/Standard template : System/Templates/Sections/Lifetime : System/Templates/Standard template : System/Templates/Sections/Help : System/Templates/Standard template : System/Templates/Sections/Appearance : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : Feature/ClientProject/SiteMetaData/MetaData
3280 08:10:27 ERROR Circular template inheritance detected in 'Validators'
3280 08:10:27 ERROR This may be caused by explicitly assigned base id's or by the setting 'DefaultBaseTemplate' in web.config.
3280 08:10:27 ERROR Template trail: System/Templates/Sections/Validators : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : System/Templates/Sections/Advanced : System/Templates/Standard template : System/Templates/Sections/Lifetime : System/Templates/Standard template : System/Templates/Sections/Help : System/Templates/Standard template : System/Templates/Sections/Appearance : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : Feature/ClientProject/SiteMetaData/MetaData
3280 08:10:27 ERROR Circular template inheritance detected in 'Workflow'
3280 08:10:27 ERROR This may be caused by explicitly assigned base id's or by the setting 'DefaultBaseTemplate' in web.config.
3280 08:10:27 ERROR Template trail: System/Templates/Sections/Workflow : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : System/Templates/Sections/Advanced : System/Templates/Standard template : System/Templates/Sections/Lifetime : System/Templates/Standard template : System/Templates/Sections/Help : System/Templates/Standard template : System/Templates/Sections/Appearance : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : Feature/ClientProject/SiteMetaData/MetaData
3280 08:10:27 ERROR Circular template inheritance detected in 'Advanced'
3280 08:10:27 ERROR This may be caused by explicitly assigned base id's or by the setting 'DefaultBaseTemplate' in web.config.
3280 08:10:27 ERROR Template trail: System/Templates/Sections/Advanced : System/Templates/Standard template : System/Templates/Sections/Lifetime : System/Templates/Standard template : System/Templates/Sections/Advanced : System/Templates/Standard template : System/Templates/Sections/Lifetime : System/Templates/Standard template : System/Templates/Sections/Help : System/Templates/Standard template : System/Templates/Sections/Appearance : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : System/Templates/Sections/Layout : System/Templates/Standard template : Feature/ClientProject/SiteMetaData/MetaData

And other details are

  • Current Version : 10.3 (initial version)
  • Headless
  • SXA
  • ReactJS
3
  • 1
    Do you have any DefaultBaseTemplate in your config?
    – Marek Musielak
    Aug 3, 2023 at 14:07
  • Yes. I have the DefaultBaseTemplate. and the id is of Standard Tempalte i.e. /sitecore/templates/System/Templates/Standard template
    – Gulam Ali
    Aug 3, 2023 at 14:12
  • What base templates are assigned to Feature/ClientProject/SiteMetaData/MetaData? Assuming you have added that to the base templates of the standard template? The value of the __Base template field (for meta data template) should be set to {00000000-0000-0000-0000-000000000000}. Aug 5, 2023 at 6:02

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.