2

We are trying to publish the item.But the language is not displaying in the popup. The langauge is already there in system/lanaguages. But it is still not displaying.

enter image description here

5
  • Is there any exception logged in log file? Aug 10, 2023 at 8:10
  • No, There is no expectation related to this Aug 10, 2023 at 8:47
  • 1
    Try this and let us know if it works getfishtank.com/blog/… Aug 10, 2023 at 9:27
  • 1
    @SumitHelaiya thanks for sharing. Followed the suggestion but finally, Restarted the application then it is working. Aug 10, 2023 at 13:40
  • I'm glad it works for you, you can mark the appropriate answer for the community. Aug 10, 2023 at 13:47

2 Answers 2

1

Try out below to resolve the issue.

1. Check The Language Definition Config

Navigate to the App_Config folder wwwroot\[your site]\App_Config and look for the LanguageDefinitions.config. If it is missing, you will need to reinstall it.

Open up the config file, and search for your language id and region. If you can't find it, reinstall this file.

2. Restart CM Server

If the Sitecore items and the config file exist, the last thing to do is restart CM and try publishing again.

Credit: https://www.getfishtank.com/blog/fix-disappearing-language-error-in-sitecore

Hope it helps!

1
  • If the question is useful can give an upvote. Aug 10, 2023 at 13:55
1

It looks like your logged-in user does not have language:write permissions for the language en. Please check that this permission is set using Security Editor or Access Viewer:

Access Viewer

This is what happens inside the "Publish Item" dialogue:

  • It takes all languages from the context database. Please note that languages are cached so you may need to clear the cache LanguageProvider - Languages or restart the server to read new languages from the database.
  • If the setting CheckSecurityOnLanguages is set to true (this is the default value), then for each language, Sitecore will check that the current user has language:write permissions. If not, this language will be skipped.
  • If there is only one language available, both "Select all" and the language checkboxes will be selected and greyed out like this:

Greyed out language

Otherwise, all language checkboxes should be selectable.

3
  • i have logged in as admin mode. Aug 10, 2023 at 9:12
  • @Rameshkumar have you ever changed the file \sitecore\shell\Applications\Dialogs\Publish\Publish.xml? Does it have the element <Border ID="Languages" />?
    – Anna Gevel
    Aug 10, 2023 at 9:27
  • @Rameshkumar another thing you can try is clearing the cache LanguageProvider - Languages if you've just added a new language.
    – Anna Gevel
    Aug 10, 2023 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.