1

I have an existing Sitecore 10.3 instance running on my local with SXA. The requirement for me is to use GraphQL to query data from my existing SXA site. In order to do that, I installed a headless service module (version 21). After I installed headless services and try to open up the GraphQL query UI and try to query data from my existing SXA tenant, It takes really long time to query data. More than 10 minutes even for a simple query. In the meantime, CMS gets really slow and eventually, it returns a bad getaway response.

I’m running my local instance in docker and I installed the headless services module by adding instructions to the runtime docker file.

I have checked the logs to get some insight but there is nothing suspicious there.

Has anybody experienced this kind of behavior after installing headless services on top of the existing Sitecore SXA site and then running GraphQL queries? Or any idea why it makes my whole CMS slow?

0

1 Answer 1

0

I've seen such an issue with my local docker instance and for me, it went well after disabling the device detection and GeoIP lookup setting.

As Device Detection module is enabled by default and requires access to Sitecore services to download and update the device database. more details here

The Device Detection module is enabled by default. However, if you want to prevent the Device Detection client from contacting the Device Detection service every day (which is the default setting), and you do not need the Device Detection functionality, then you can disable the module.

Patch:

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:role="http://www.sitecore.net/xmlconfig/role/">
  <sitecore role:require="Standalone or ContentManagement or ContentDelivery">
    <settings>
        <setting name="DeviceDetection.Enabled">
            <patch:attribute name="value" value="false" />
        </setting> 
        <setting name="GeoIp.PerformLookup">
            <patch:attribute name="value" value="false" />
        </setting>  
    </settings>
  </sitecore>
</configuration>

Hope it helps!

2
  • Unfortunatly this does not fix the issue for me.
    – Ashan
    Commented Aug 17, 2023 at 23:09
  • After communicating with Sitecore support and doing our own investigations, it turns out the issue in our local environment is related to low memory for our containers. By default, docker allocates 1GB memory for a docker container. After increasing it explicitly via docker-compose, the local environment including GraphQL queries performed without any issues. More details about how to increase the memory of a docker container can be found here - medium.com/@mitya_1988/…
    – Ashan
    Commented Sep 5, 2023 at 21:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.