0

I can see data in Experience Analytics , but there is nothing in Experience Profile.
Do I need to enable any configuration.

Using Sitecore v10.1.3.

enter image description here

1

3 Answers 3

1

By default XConnect Search Indexer only indexes Known Contacts. Therefore if this is a dev environment, or if your site does not identify (using identifyAs()) contacts during there visit, then it may just be that there are no known contacts to index.

You can switch to start indexing annonymous contacts by accessing this config file:

<collection-search-root>\App_Data\jobs\continuous\IndexWorker\App_Data\Config\Sitecore\SearchIndexer

Then updating this setting to true:

<IndexAnonymousContactData>false</IndexAnonymousContactData>

You can then rebuid the xDB index by going opening a admin CMD window, navigating to indexer root:

<collection-search-root>\App_Data\jobs\continuous\IndexWorker\

And running :

Sitecore.XConnectSearchIndexer.exe -requestrebuild

Note: this can can resource implications if you are doing this in prod environment.

1

There may be many reasons for this, please verify the below points if there is no data present on Sitecore experience profile dashboard.

  1. Make sure the xConnect Service is running

  2. Make sure the below setting is true in the file (if there are Anonymous Contacts) C:\\root\App_data\jobs\continuous\IndexWorker\App_data\Config\Sitecore\SearchIndexer\sc.Xdb.Collection.IndexerSettings.xml

    <IndexAnonymousContactData>true</IndexAnonymousContactData>
    
  3. Enable TCP/IP setting from SQL Server Configuration Manager

  4. Rebuild the core. To invoke the rebuild request command:

    • Go to the server where the xConnect Search Indexer is running and open command line
    • Navigate to the folder that contains the service – for example: C:\inetpub\wwwroot\\App_Data\jobs\continuous\IndexWorker.
    • Run XConnectSearchIndexer -rr (alternatively XConnectSearchIndexer -requestrebuild). The command registers a small document in the live core signaling that the rebuild should be started. The xConnect Search Indexer will notice the document and start the rebuild process

Hope this helps.

1

In order to track analytics data to the correct database please check the following:

  • check whether the "collection" connection string is pointed to the right ShardMapManager database;

  • check whether xconnect connection strings on CD instances are pointed to the correct xConnect;

  • check whether the correct server name and database name is set in the following tables:

    [_Xdb.Collection.ShardMapManager].[__ShardManagement].[ShardsGlobal]
    [_Xdb.Collection.Shard0].[__ShardManagement].[ShardsLocal]
    [_Xdb.Collection.Shard1].[__ShardManagement].[ShardsLocal]
    

If everything is set correctly please try to restart CD and xConnect instances and check whether the issue is reproducible afterwards.

The absence of data in the Experience Profile could be due to the following reasons:

  1. There are no identified contacts in Shards. By default indexing of anonymous contacts is disabled. In order to enable it please refer to the following article: https://doc.sitecore.com/xp/en/developers/103/sitecore-experience-platform/enable-indexing-of-anonymous-contacts-in-the-xdb-index.html
  2. In case there are identified contacts in Shards and you do not want to enable indexing of anonymous contacts in order to see data in Exp Profile please perform the rebuild of the xdb index: https://doc.sitecore.com/xp/en/developers/103/sitecore-experience-platform/rebuild-the-xdb-index-in-solr.html

Please be sure that "IndexPIISensitiveData" setting in the sc.Xdb.Collection.IndexerSettings.xml file is "true" in the "xdbsearch" and in the "xdbsearchworker" instances. Please run rebuild on your "xdbsearchworker" instance using .\Sitecore.XConnectSearchIndexer.exe -rr command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.