I created a new XM1 developer environment using the official Container Deployment Package, using PowerShell 7.3.6 elevated. After running Compose-Init.ps1 and docker compose up -d, when trying to hit https://xm1cm.localhost I receive a certificate error, because the site is served using the Traefik Default Certificate, rather than the signed one created by the compose-init.ps1 process. Examining the Traefik logs shows this error:

level=error msg="Unable to append certificate -----BEGIN CERTIFICATE-----\r\n[key removed]\r\n-----END CERTIFICATE-----\r\n to store: unable to generate TLS certificate : tls: failed to parse private key" tlsStoreName=default

1 Answer 1


This appears to be related to an incompatibility with SitecoreDockerTools and PowerShell 7.3. A colleague (Jason Bert) was able to get past this by running with PowerShell 5.1 (though I run into a separate issue there).

I was able to resolve this by using the "mkcert" utility as documented here:


mkcert -cert-file traefik\certs\xm1cm.localhost.crt -key-file traefik\certs\xm1cm.localhost.key "xm1cm.localhost"

for CM, CD, and ID roles.

Reported to Sitecore as a defect (CS0399761).

** When I tried to run compose-init.ps1 with PowerShell 5.1, I ran into this error:

> A parameter cannot be found that matches parameter name 

So neither PowerShell 5.1 nor 7.3 runs cleanly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.