0

enter image description here

I updated the session timeout to 60 minutes in the sessionState section of web.config. After the 60 minutes of time out, the application throws a server error with no event log captured. but the same works as expected when the timeout was 20 minutes. This application is on Sitecore 9.3.

What might be causing this?

Code snippet updated

3
  • Please share more details like the server error snapshot you get and config update you made to understand what went wrong.
    – Ghanendra
    Sep 4, 2023 at 13:22
  • Is this in test or production environment? A larger session means more users session will be stored in memory, so this could possibly lead to memory issue. The server error will give an indiciator as to the cause. Sep 5, 2023 at 8:07
  • Added additional information, it is happening in non production too Sep 12, 2023 at 13:35

1 Answer 1

0

This answer might help: https://stackoverflow.com/a/66921362/159153

Here is the text from that answer:

I am also facing the same issue with Sitecore 9.3. You can try the below solution if it works.

Set ExpireTimeSpan in Sitecore.Owin.Authentication.config which is given below for both "PreviewCookieAuthentication" and "CookieAuthentication" to 00:20:00.

Then set in sitecore.config.

It should work for 20 minutes. I am facing an issue when I increase the timeout value from 20 to 30 minutes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.