We are running sitecore with docker in version 10.1.2 (rev. 006578).

On the customers laptop, apparently due to the companies security policy, the docker containers could not communicate with each other. As a result, xconnect was unhealthy because it could not reach the container with the SQL Server.

Thanks to the solution provided here https://sitecore.stackexchange.com/a/26177/1425, we solved this by setting the hostname attribute in docker-compose.yml for all services, always repeating the container id, like here:


This was the only change. It solved the issue with the containers communicating to each other but when we try to log in to Sitecore, the redirects are broken now, because they redirect to http and not https protocols. For example when calling https://cm.mum.localhost/sitecore/admin, the redirect goes to:

enter image description here

The same in any step that follows. When we correct the addresses by adding the 'https://' in the browser's address bar, all works fine.

We checked sites.config and it looks fine:

enter image description here

Any idea how we can fix this?

1 Answer 1


In the end, this turned out to be a problem of the traefik certificate.

The script docker/scripts/installCertificate.ps1 when executed with all permissions under the local user account in admin mode, had not thrown any error. But also not installed the certificate.

Solution was to log in on the laptop as an Administrator, run installCertificate.ps1 there. Then find the certificate in the certificate manager, export it, and import it to a trusted folder where the local user has access to.

It took a while to find out because Firefox needed to be restarted before it really tried to find the certificate again. A private window did not do the trick.

I hope this will save some time to other users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.