I have enabled federated authentication for Sitecore frontend website. But now I see external login button(login with google) on the sitecore login page. How can I remove this button from the sitecore login page but have federated authentication enabled for the website login

  • Check the documentation doc.sitecore.com/xp/en/developers/103/… . Find IdentityProvidersPerSitesMapEntry. Make sure that shell and 'admin' sites are not included in the map.
    – Marek Musielak
    Commented Sep 8, 2023 at 12:47
  • @MarekMusielak I still see "go to login" button after applying regex for shell and admin Commented Sep 8, 2023 at 13:19
  • You have done your login for your front end website wrong. It shouldn't be using the Sitecore identity server - that is for CM users. Your front end users should be done separately. You will need to rearchitect your front end authentication so that it does not use the CM authentication functionality.
    – Richard Seal
    Commented Sep 8, 2023 at 15:44
  • Richard - identity server can be used for both front and back end. If you set the loginPage parameter on site node (I.e. loginPage="$(loginPath)your-site-name/SitecoreIdentityServer/IdS4-WsFederation') and also set requireLogin=true. Then the front end user will bypass and never see the login page. Commented Sep 8, 2023 at 17:12

1 Answer 1


If you really just need to hide a button on the identity server front page, the simplest solution would be to just stick some CSS on the page to hide it.

To do this, access identity server file system and navigate to:


Then in the head of the document add:

    .external-providers a {display:none}

You might need to play around with CSS if you have multiple external providers and only want to select one of them.

Some more info on using identity server to link different sitecore domains to different external providers: https://deanobrien.uk/sitecore-identity-server-mapping-custom-fields-and-roles-from-azure-ad/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.