5

On our Sitecore 8.1 site, we had a new content author role setup for the French-Canada culture. The problem is that if I log in as a user with this role and navigate to the Content Editor, I see all fields in compare/translate mode (see the screenshot, below).

enter image description here

I checked the versions tab, in an attempt to disable the compare/translate mode, but I do not see the Translate button there (see the screenshot, below).

enter image description here

Can you please let me know how to fix this?

Note that we are using Claytablet integration for translations.

6

You are correct that the Translate button is what you are looking for. Since you are not seeing it when logged in with your user with the new role, your new role likely does not have the necessary sitecore/Sitecore Client Translating role that is required in order to see the button.

Quick Fix

Try logging in as an administrator and see if the button will display for you. If so, temporarily add the sitecore/Sitecore Client Translating role to the user that is experiencing the issue, then log in with the user with the new role, navigate to the Content Editor and click the Translate button to disable the duplicate display.

Further Investigation

If the above quick-fix doesn't do the trick, try the below to further investigate the issue. Note that for each of the below, you will (at the very least) need some familiarity with the Access Viewer (see official docs) and with how Sitecore calculates access rights for a security account on an item (see official docs).

Investigating the Translate Chunk of the Ribbon

In your screenshot, you are missing the entire Translate chunk of the ribbon, not just the Translate button itself. As such, we start by first investigating the Translate chunk of the ribbon.

Log into Sitecore as an administrator, switch to the Core database, navigate to the Content Editor and traverse the tree until you find the /sitecore/content/Applications/Content Editor/Ribbons/Chunks/Translate item. This item represents the Translate chunk that (should) display in your Ribbon. Click on the Security tab, then click the Details button in the Security chunk of the ribbon (see the screenshot below).

enter image description here

In the resulting window, note the security permissions that have been assigned for this item (see the sceenshot, below). Note that the security permissions that have been assigned reflect the security permissions assigned directly (not accounting for inherited security settings) to the entire Translate chunk in the ribbon.

enter image description here

The security settings above are the OOTB settings for Sitecore 8.1 (I checked each version). If your security settings are different, either change them by clicking on the Assign button (next to the Details button in Security tab's ribbon) or use information gained to help you figure out which security account you should assign (even temporarily, if necessary) to your test user or new role in order to fix the issue.

Investigating the Translate Button

If you are unable to find any differences on the Translate chunk's item, try looking at the security settings for the Translate button's item, /sitecore/content/Applications/Content Editor/Ribbons/Chunks/Translate/Translate. If you are still unable to find the source of your issue, try opening up the Access Viewer (while still in the Core database) and looking there.

You will want to select the role or test user experiencing the issue via the Account button or Roles and users quick selection box at the top left, and then drill down to the /sitecore/content/Applications/Content Editor/Ribbons/Chunks/Translate/Translate item (see screenshot, below).

enter image description here

Be sure to look at the security settings along the way, or click on the Read access right of the desired item to see which security settings in the ancestry impacted the final result (see screenshot, below).

enter image description here

Sitecore Support

Whether or not the above helps you, this issue is worthy of a Sitecore Support ticket, since the duplicated field view really shouldn't display for users without the sitecore/Sitecore Client Translating role.

If the above does not work for you, I would definitely file a Sitecore Support ticket and let them know the issue, what you did to try to investigate and resolve it, and work with them to investigate the issue further.

Additional References

| improve this answer | |
  • 1
    You are awesome. Quick fix solved the issue. Thanks a lot :) :) – Karthik Dec 30 '16 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.