0

I am trying to install Sitecore 9.2 but at the end of the process, I am getting an error:

cannot validate argument on parameter FilePath

SitecoreSolr_AddSchemaUniqueKeyField [1] : SetXml
Install-sitecoreConfiguration: Cannot validate argument on parameter 'FilePath'. The " Test-Path $_
-PathType Leaf " validation script for the argument with value
"C: \solr\solr-9.3.0\server\solr\obsSad_core_index\conf\managed-schema" did not return a result of True. Determine why the validation script failed, and then try the command again.
At C: \Users\
\Downloads\ Sitecore\XPO-SingleDeveloper.ps1:74 char: 1
+ Install-SitecoreConfiguration @singleDeveloperParams *>&1 | Tee-objec
CategoryInfo
: NotSpecified: (:) [Write-Error], WriteErrorException + FullyQualifiedErrorId: Microsoft.PowerShell.Commands .WriteErrorException, Install-SitecoreConfiguration
[TIME] 00:04:42
Invoke-SetXmlTask: Cannot validate argument on parameter 'FilePath'. The " Test-Path $_ -PathType Leaf m validation script for the argument with value
"C: \solr\solr-9.3.0\server\solrlobsSad_core_index\conf\managed-schema" did not return a result of True. Determine why the validation script failed, and then try the command again.
At C: \Prodram Files\ WindowsPowerShell\ Modules\ SitecoreInstallFramework\2.3.0\Public\ Install-SitecoreConfiguration.ps1:641 char:47
& $entrv.Task.Command @paramSet | Out-Default
+ CategorvInfo
InvalidData: (:) [Invoke-SetXmlTask]. ParentContainsErrorRecordException
FullyQualifiedErrorld
:ParameterArgumentValidationErrorInvoke-SetXmlTask

And yet the file is present in the specific folder:

file system

The XP0-SingleDeveloper.ps1 file is configured properly. Thanks for any information you could provide, cheers.

2
  • 1
    Replace your error screenshots with error text for SEO reasons. Commented Sep 19, 2023 at 15:02
  • The problem has been solved by switching Solr version from 9.3 to 8.11.2
    – Daniel
    Commented Sep 20, 2023 at 9:07

2 Answers 2

0

You should always check which version of Solr is compatible with the version of Sitecore you're planning to use.

You're installing Sitecore 9.2 which means you should use Solr 7.5. Working with other version (like you attempted with Solr 9.3.0) can cause installation errors which are easy to notice, or can cause issues while using Solr with Sitecore which can be quite hard to investigate in the future.

Here is the link to Solr Compatibility tables for Sitecore:

https://support.sitecore.com/kb?id=kb_article_view&sysparm_article=KB0227897

And here is current version of the table: enter image description here

1
  • Thank you Marek, will keep it in my mind! (:
    – Daniel
    Commented Sep 20, 2023 at 11:47
0

I've faced Path related issues with installation and It could be due to an incompatible SIF version. (link)

As per your error screenshot you are using SIF 2.3.0. You can try SIF 2.1.0 for Sitecore 9.2 installation.

There are helpful commands in the above link to check, install or uninstall SIF on your machine.

I used below command to check the version installed on my machine:

Get-Module SitecoreInstallFramework –ListAvailable

Then uninstall the SIF 2.3.0 using below command:

Uninstall-Module -Name SitecoreInstallFramework -RequiredVersion 2.3.0

And installed SIF 2.1.0 using below command:

Install-Module -Name SitecoreInstallFramework -RequiredVersion 2.1.0

Hope it helps!

1
  • Hi @SumitHelaiya, thank you for the information, but unfortunately it didn't help. The same issue that the script couldn't validate argument on parameter 'FilePath'.
    – Daniel
    Commented Sep 20, 2023 at 6:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.