1

I am getting an error in my SC10 AKS instance in experience profile when I click on a contact:

URL http://testabc.com/sitecore/api/ao/v1/contacts/{9cc8524k-b9dd-0000-0000-066f49mf968eg/image?w=170&h=170

Exception System.Exception: Language must be specified using Accept-Language header.
at Sitecore.Cintel.Endpoint.Plumbing.NegotiateLanguageFilter.OnActionExecuting(HttpActionContext actionContext)
at System.Web.Http.Filters.ActionFilterAttribute.OnActionExecutingAsync(HttpActionContext actionContext, CancellationToken cancellationToken)
--- End of stack trace from previous location where exception was thrown ---

I see in the Server variables, Accept-Language is missing.

Any idea from where Accept-Language Server variable is created? How can I fix it?

5
  • Accept-Language HTTP header is usually added by your browser when it sends a request. Do you see this header under Request Headers in the browser Network tab?
    – Anna Gevel
    Commented Oct 4, 2023 at 12:54
  • yes, Its present in request header but not in Server variables. Commented Oct 4, 2023 at 13:29
  • I have one more instance where its present in Server variables and it works fine. Commented Oct 4, 2023 at 13:29
  • Thanks for checking, do you have any rewrite rules that can be removing headers or server variables?
    – Anna Gevel
    Commented Oct 4, 2023 at 21:04
  • 1
    No, there is no such redirect rule. I feel its something related to AKS ingress settings but I am not sure. I'll update here if I find a solution. Commented Oct 5, 2023 at 9:23

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.