9

I'm trying to save some information into SQL through WFFm's Save action & couldnt get it right :( i have configured wffm connection string as enter image description here

May i know what is the default connectiostring name for WFFM ? is it 'wffm' or 'wfm' Some analysis from my end:

Sitecore.WFFM.Dependencies.config

enter image description here

Sitecore.Forms.config

enter image description here

  • Which version of Sitecore and WFFM do you use? – Tamás Tárnok Jan 2 '17 at 8:35
  • Sitecore 8.1 Update-1 & WFFM 8.1 Update-1 – Balaji Kuppuswamy Jan 2 '17 at 8:39
  • Xdb.Enbaled=true on your Sitecore instance or you use CMS-Only mode? – Tamás Tárnok Jan 2 '17 at 8:42
  • Its 'off' since i do not have XDB setup in my instance. – Balaji Kuppuswamy Jan 2 '17 at 8:44
9

Regarding to the following blogpost (https://citizensitecore.com/2016/05/11/wffm-and-cms-only-mode-in-sitecore-8-1/) by default Sitecore saves the WFFM form values in MongoDB after Sitecore 8.0 version.

The default connectionStringName is wfm. To make this work on CMS-Only instance you need to overwrite the connectionStringName in the sqlFormsDataProvider in Sitecore.WFFM.Dependencies.config file.

Solution step by step

  1. First, you need to take the empty Sitecore_Wffm SQL database that was placed in the %webroot%/Data folder and attach it to your SQL Server.
  2. Next, you must add a new connection string in App_Config/ConnectionStrings.config for this database. <add name="wfm" connectionString="insert connection string here" /> Yes, the name of this connection string should be wfm. In Sitecore.Forms.config, there is a WFM.ConnectionString setting that specifies the name of the connection string to use. It is wfm out of the box. **For the record, while this step isn’t in the installation guide for 8.1-compliant versions of WFFM, I have seen it in official documentation somewhere, I just can’t seem to recall where. And if it’s that difficult to find, it’s a problem.
  3. Finally, in Sitecore.WFFM.Dependencies.config, in the /sitecore/wffm/analytics node, there is an element called <formsDataProvider>.

Update this connection string name to match what is in Sitecore.Forms.config and you should be golden!

  • Is there any reason you can't just patch WFM.ConnectionString from Sitecore.Forms.config instead (setting this to wffm)? – Matthew Dresser Jun 26 '18 at 10:33

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.