Installed Sitecore Identity server 7.0 on the exiting sitecore instance(10.3). When I try to access the identity server directly from browser (https://idenityserver.local) I keep getting "500 Internal Server Error".

I ran the "dotnet .\Sitecore.IdentityServer.Host.dll" on PowerShell and seeing this

[11:36:43] Sitecore.Framework.Plugin.Web.WebCommand [Information] Starting web host [11:36:43] Duende.IdentityServer.Startup [Information] Starting Duende IdentityServer version "6.0.4+9dfb7e94e795f86sdfs586sdf70aae05e4e07" (".NET 6.0.2") [11:36:43] Duende.IdentityServer.Startup [Information] Using the default authentication scheme "idsrv" for IdentityServer [11:36:43] ConfigurePipeline [Error] Pipeline completed with error System.Exception: Error processing block: System.Lazy`1[[Microsoft.AspNetCore.Hosting.IStartup, Microsoft.AspNetCore.Hosting.Abstractions, Version=, Culture=neutral, PublicKeyToken=adb9793829ddae60]] ---> System.ArgumentNullException: Value cannot be null. (Parameter 'source')

Seems like identity server and a version mismatch OR issue with the Microsoft.AspNetCore.Hosting.Abstractions package?

FYI - dotnet --info

dotnet --info from cmd

Reason why I am getting this?

4 Answers 4


I have seen this error before when installing a newer .net version on an existing environment. one think helped for me is to deploy on a clean folder or environment. By just placing it in the same folder can cause older files remain and still try to reference the old version.

Kind regards


I recently got this issue for my fresh installation for Sitecore 10.3 XM using SIF. Here are a few things/prerequisites you need to check and reinstall.

1. Check .NET Framework Version:

Ensure that you have .NET Framework 4.8.0 or later installed. You can check the installed version using the below PowerShell command. If it's less than 4.8.0, you should install it from the official Microsoft website.

$release = Get-ItemPropertyValue -LiteralPath 'HKLM:SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full' -Name Release
switch ($release) {
    { $_ -ge 533320 } { $version = '4.8.1 or later'; break }
    { $_ -ge 528040 } { $version = '4.8'; break }
    { $_ -ge 461808 } { $version = '4.7.2'; break }
    { $_ -ge 461308 } { $version = '4.7.1'; break }
    { $_ -ge 460798 } { $version = '4.7'; break }
    { $_ -ge 394802 } { $version = '4.6.2'; break }
    { $_ -ge 394254 } { $version = '4.6.1'; break }
    { $_ -ge 393295 } { $version = '4.6'; break }
    { $_ -ge 379893 } { $version = '4.5.2'; break }
    { $_ -ge 378675 } { $version = '4.5.1'; break }
    { $_ -ge 378389 } { $version = '4.5'; break }
    default { $version = $null; break }

if ($version) {
    Write-Host -Object ".NET Framework Version: $version"
} else {
    Write-Host -Object '.NET Framework Version 4.5 or later is not detected.'

2. Install .NET Core SDK:

Make sure you have .NET Core 6.0 SDK or a later version installed. It's recommended to reinstall it even if you have it already. You can download it from the official .NET Core download page.

3. Install .NET Core Windows Hosting Bundle:

Ensure you have .NET Core 6.0 Windows Hosting Bundle or a later version installed. It's important to reinstall the hosting bundle, even if it's already installed. You can download it from the official .NET Core download page.

4. Install Web Deploy 3.6:

Make sure you have Web Deploy 3.6 installed. You can download it from the official Microsoft website.

5. Check URL Rewrite 2.1:

Verify that URL Rewrite 2.1 is installed. You can download from here.

  • Thank you @Raman, I have all the dependencies with proper versions. But will try to re-install all and see.
    – Sun
    Commented Oct 25, 2023 at 19:15

You are right, most probably it is a version mismatch issue. As per the official Upgrade Guide (Sitecore Identity 7.0.328).

Sitecore Identity Server is compatible with the client and server operating systems that support ASP.NET Core 6.0.

Sitecore Identity Server requires ASP.NET Core 6.0 Runtime – Windows Hosting Bundle 6.0.4 or later.

If you already installed the Windows hosting bundle then uninstall it download the compatible version and install it. Download link

Hope it helps!

  • Thank you @Sumit, will try to reinstall .Net Core and see.
    – Sun
    Commented Oct 25, 2023 at 19:13
  • Re-installed all the dependencies again, even installed newer version of Windows Hosting Bundle 7.0+, still no luck. @SumitHelaiya
    – Sun
    Commented Nov 1, 2023 at 14:52

If you put an unexpected file in the Localization dir e.g. copy a folder or just put a test.xml and restart the Identity server it will not start up properly until you delete the file/folder. In our case the Copyrights were drag and dropped in the Localization which caused the Culture error. Moving the files back to their places and restarting the server resolves it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.