0

I have recently updated my local Sitecore setup to 10.3 from 10.1 and found out that the media items are not loading in the list view of the Select Media dialogue box while the tree view working fine.

Sitecore media dialogue box not showing media items

I have checked the Sxa site settings and related speak items in the core db from the earlier version, and they are all correct, also rebuilt the Sitecore master index multiple times.

Also, there are no error logs in the search.log file. The solr query for fetching media builds up as:

INFO Solr Query - ?q=(((_path:("524593b73531496493721366efae1302") OR (_path:("d0d35b6ad7b74a51aa54938cd8151b24") OR _path:("14afcd344f2a42e881d405fb6c83d226"))) AND _language:("en")) AND (_template:("f1828a2c7e5d4bbd98ca320474871548") OR _template:("daf085e8602e43a68299038ff171349f") OR _template:("c97ba92380094858bdd5d8be5fccecf7") OR _template:("eb3fb96cd56b4ac997f8f07b24bb9bf7"))) AND _val_:__boost&start=0&rows=20&fl=*,score&fq=_indexname:(sitecore_master_index)&facet=true&facet.field=calculateddimension_sm&f.calculateddimension_sm.facet.mincount=0&facet.field=_templatename&f._templatename.facet.mincount=0&facet.field=__smallupdateddate_tdt&f.__smallupdateddate_tdt.facet.mincount=0&wt=xml

The response in the network tab for

-/item/v1/sitecore/shell?facetsRootItemId=%7B7F43D3D0-CAC6-45D8-96FE-B76F4A117F9B%7D&search=&root=%7B14AFCD34-4F2A-42E8-81D4-05FB6C83D226%7D&searchConfig=%7BB0DF45DF-EA31-4C11-9E34-98B41DF549C5%7D&sc_content=master&language=en&format=%24convert_date_to_friendly_format&fields=__Created%7CDimensions&pageIndex=0&pageSize=20:

is as below :

enter image description here

Any suggestion or help is appreciated. Thanks in advance.

UPDATE: After doing the following steps in order, the images are loading:

  1. Populated Sitecore master index.
  2. Rebuild the master index
  3. Restarted the docker and all the containers.
2
  • Comments have been moved to chat; please do not continue the discussion here. Before posting a comment below this one, please review the purposes of comments. Comments that do not request clarification or suggest improvements usually belong as an answer, on Sitecore Meta, or in Sitecore Chat. Comments continuing discussion may be removed.
    – Richard Seal
    Oct 29, 2023 at 8:54
  • Instead of adding solution as update in the question, you should answer your question and mark it as accepted. Oct 30, 2023 at 9:16

1 Answer 1

0

Recommended Approach from your answer would be -

  • You should Re-Index the tree rather than reindex all as shown below.

enter image description here

  • Then restart the container.
  • This will limit the scope of re-indexing and won't index unwanted items.

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.