1

I'm installing Sitecore 9.1.0 locally using SIF and it reaches about step 70 of 85, then fails with the error

Could not complete request for https://localhost:8984/solr - Unable to connect to the remote server

This is the message in the console window:

[---------------------------- SitecoreSolr_CreateCores [1] : ManageSolrCore ------------------------------------------]
[SitecoreSolr_CreateCores [1]]:[Requesting] https://localhost:8984/solr
WARNING: [1/5] Request Failed: Unable to connect to the remote server
[SitecoreSolr_CreateCores [1]]:[Requesting] https://localhost:8984/solr
WARNING: [2/5] Request Failed: Unable to connect to the remote server
[SitecoreSolr_CreateCores [1]]:[Requesting] https://localhost:8984/solr
WARNING: [3/5] Request Failed: Unable to connect to the remote server
[SitecoreSolr_CreateCores [1]]:[Requesting] https://localhost:8984/solr
WARNING: [4/5] Request Failed: Unable to connect to the remote server
[SitecoreSolr_CreateCores [1]]:[Requesting] https://localhost:8984/solr
WARNING: [5/5] Request Failed: Unable to connect to the remote server
Install-SitecoreConfiguration : Could not complete request for https://localhost:8984/solr - Unable to connect to the remote server
At C:\Sitecore\Sitecore 9.1.0\XP0-SingleDeveloper.ps1:74 char:1
+ Install-SitecoreConfiguration @singleDeveloperParams *>&1 | Tee-Objec ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Install-SitecoreConfiguration
Invoke-ManageSolrCoreTask : Could not complete request for https://localhost:8984/solr - Unable to connect to the remote server
At C:\Program Files\WindowsPowerShell\Modules\SitecoreInstallFramework\2.1.0\Public\Install-SitecoreConfiguration.ps1:641 char:25
+                         & $entry.Task.Command @paramSet | Out-Default
+                         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
+ FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Invoke-ManageSolrCoreTask

I've set up Solr 7.2.1 successfully (using the usual NSSM tool) and can start and stop the service via the windows services utility without any issues. I can also view the Solr dashboard in the browser and see and manage cores etc. I presume there must be something wrong in how Solr is set up though which causes this issue. I checked the Solr logs for any issues, but they don't show any errors.

2
  • 1
    Shot in the dark. Looks like you are using SIF 2.1.0, whereas I think the supported version for SC 9.1.0 is SIF 2.0.0. Also, try uninstall-sitecoreconfiguration command first to ensure no cores in place failing yo be overwritten Oct 31, 2023 at 12:37
  • I thought I had checked that but was following internal documentation, rather than the original Sitecore ones. You're quite right about the SIF version. As per this doc (page 29) it requires 2.0.0 dev.sitecore.net/~/media/85019670EECE4D008EEB3AD7037CE456.ashx Oct 31, 2023 at 13:26

1 Answer 1

2

Looks like you are using SIF 2.1.0 , For Sitecore 9.1.0 try using SIF 2.0.0 It should work.

Install-Module -Name SitecoreInstallFramework -RequiredVersion 2.0.0

Hope this helps!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.