1

In Sitecore 8.1-3 whenever I go in to the Experience Profile and select a contact and view either the Overview tab or the Profiling tab I see the following error on the screen: "There is no row at position 0". What does this mean?

I found this posting - https://stackoverflow.com/questions/28783328/sitecore-8-revision-150121-analytics-mongodb-error-there-is-no-row-at-pos - but that is not really helpful. It seems to say that this is just a coding bug. Does that mean it can safely be ignored?

EDIT: adding log info

When I look in the Sitecore logs I see the following:

3836 14:13:51 INFO  Experience Profile view profile-pattern-matches called
3836 14:13:51 ERROR There is no row at position 0.
Exception: System.IndexOutOfRangeException
Message: There is no row at position 0.
Source: System.Data
   at System.Data.RBTree`1.GetNodeByIndex(Int32 userIndex)
   at System.Data.DataRowCollection.get_Item(Int32 index)
   at Sitecore.Cintel.Reporting.Contact.ProfileInfo.Processors.FindBestPatternMatchAndApplyToProfileInfo.ApplyPatternToOneProfile(ReportProcessorArgs args, DataRow profileRow)
   at Sitecore.Cintel.Reporting.Contact.ProfileInfo.Processors.FindBestPatternMatchAndApplyToProfileInfo.ApplyPatternsToResultTable(ReportProcessorArgs args, DataTable resultTable)
   at (Object , Object[] )
   at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args)
   at Sitecore.Cintel.Reporting.PipelineViewProvider.GenerateContactView(ViewParameters viewParameters)
   at Sitecore.Cintel.Endpoint.IntelController.Get(ViewParameters viewParams, Guid contactId, String viewId, String id)
2
  • What have you done so far to debug/research the issue? Anything in the logs?
    – Richard Seal
    Jan 3 '17 at 20:27
  • Added log info to post Jan 3 '17 at 20:37
2

This error happens because there are no pattern and profile cards.

It is fixed in the 8.2 Initial release (release notes):

Experience Profile The error: "There is no row at position 0" appears in the Experience Profile for contacts with personal info and when there are no pattern cards.

https://dev.sitecore.net/Downloads/Sitecore%20Experience%20Platform/82/Sitecore%20Experience%20Platform%2082%20Initial%20Release/Release%20Notes

As a workaround, you can just add one pattern and profile card

2

I believe I figured out the problem. We had not set up any Profile Cards or Pattern Cards. And so I think the system was displaying that error because it was expecting to find Profile or Pattern Cards. Once I added a Profile Card and a Pattern Card the error went away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.