2

I am facing a weird issue with WFFM.

I have used WFFM module for contact us page in website. In the form i have few required fields which i marked as required using WFFM. Most of the time form validation works.But after few hours same page gives exception. This issue comes in some regular intervals( like 1-2 day)

The immediate fix which i am doing is the reset IIS or recycle app pool. sometimes reset IIS not works in that case i have to do a reset IIS+ web.config modification(any kind of modification).

Is there any permanent Fix for this?

I am using Sitecore 8.1(update 1) + supported WFFM also, Language fallback is enabled.

I am sensing this issue is related to Cache.

Below is the exception details.

enter image description here

Please let me know if anyone has solution for this.

Thanks

5
  • 1
    did you add any custom validation to fields & missing error message for them ? Your Error log shows something like that. – Balaji Kuppuswamy Jan 5 '17 at 14:01
  • Hi @BalajiKuppuswamy No i am not using any custom validation. – Pankaj Prasad Jan 5 '17 at 15:02
  • 1
    Are you using 'FileUpload' FieldType of WFFM ? if yes please read this for implementation. ggullentops.blogspot.in/2016/05/… . Also worth looking into below link since your exception logs show 'DynamicValidationBase' related issue stackoverflow.com/questions/38278133/… please revert if it resolves your issue. – Balaji Kuppuswamy Jan 5 '17 at 16:56
  • 1
    As language fallback is enabled, I assume you have a multilingual solution. Please read this ggullentops.blogspot.be/2016/02/… to set multilingual error messages. Not sure if it will fix your error, but worth a try (as you will read, error messages are cached indeed and maybe you get an empty value when someone fills the form first in a language that has no error message set). Can elaborate in an answer if applicable. – Gatogordo Jan 5 '17 at 17:31
  • Hi @Gatogordo , I went to the location "/sitecore/system/Modules/Web Forms for Marketers/Settings/Meta data/Mvc Validation Error Messages" and enabled fall back for all kind of error messages.. its been 6 days in Row.. didn't got the error . Hope that is resolved the issue.. will keep you posted. – Pankaj Prasad Jan 11 '17 at 9:35
4

As language fallback is enabled, I assume you have a multilingual solution. Please read this to set multilingual error messages. As you will read, error messages are cached indeed and maybe you get an empty value when someone fills the form first in a language that has no error message set.

Setting the language fallback on the error message fields (located in /sitecore/system/Modules/Web Forms for Marketers/Settings/Meta data/Mvc Validation Error Messages) should fix it as well as that would lead to a version of your error messages is all languages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.