2

I have installed Sitecore 10.3.1 and now I am trying to Install Sitecore Connect for Content Hub on-prem as mentioned in this document https://doc.sitecore.com/xp/en/developers/connect-for-ch/51/connect-for-content-hub/install-sitecore-connect-for-content-hub-on-prem.html.

I run this script:

<path where you extracted the SCCH SIF installation script>\deploy.ps1 `
-ScchWdpPackage “<path of SCCH module installation package downloaded>” `
-InstanceName “<Sitecore instance name>” `
-InstanceUrl “<Sitecore instance url>” `
-SitecoreAdminUser “<Sitecore admin user name>” `
-SitecoreAdminPass “<Sitecore admin password>” `
-SqlInstanceName “<Sitecore SQL Database prefix name>” `
-SqlUser “<SQL server user name>” `
-SqlPass “<SQL server password>” `
-SqlServerName “<SQL server name>” `
-SkipDatabaseInstallation “<true or false for skip database installation>”

But after running this, I am getting below error:

Method not found: 'Void Microsoft.Extensions.Caching.Memory.MemoryCache..ctor(Microsoft.Extensions.Options.IOptions`1<Microsoft.Extensions.Caching.Memory.MemoryCacheOptions>)'.

enter image description here

Please suggest.

2

2 Answers 2

0

Please see if you have the compatible version of connector installed from Sitecore Connect™ for Content Hub compatibility table

Also, to cross check the Microsoft.Extensions.Caching.Abstractions version with the backup of the web.config before the installation.

enter image description here

1
  • Thanks, @Shiham for your response. I have checked content hub version is correct as well as Microsoft.Extensions.Caching.Abstractions dll version is also correct. Feb 19 at 8:26
0

Not sure how you are currently running your website, I assume locally.

Maybe it helps when looking into the troubleshoot Sitecore refers: https://doc.sitecore.com/xp/en/developers/connect-for-ch/51/connect-for-content-hub/troubleshooting-scch.html#azure-deployment-throws-could-not-load-file-or-assembly-microsoftextensionscachingabstractions-error

Underneath that section you also see a few on-premise issue you can look into.

1 last think just to be sure: you run your script for Sitecore version 10.3.1 there is a note underneath the script: If you are deploying SCCH to Sitecore 10.1 and later, you must set the SkipDatabaseInstallation parameter to $true.

I assume you set this parameter to true.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.