0

I configured the Arabic language version at the site level and selected the English as the fallback language.

enter image description here

Then, enabled the item language fallbackand language fallback.

enter image description here

After that,created the data source for English only and selected the Arabic language version without a version number. It is displaying fallback content from English, as shown below.

enter image description here

Next, I configured this on one of my page items, and the language fallback content is rendering properly in the Experience Editor. However, it is not rendering the content in the headless application.

enter image description here

Could someone help me resolve this issue? Thanks.

2 Answers 2

1

For language fallback you need to configure it for xmcloud instance and experience edge: https://doc.sitecore.com/xmc/en/developers/xm-cloud/enable-and-set-up-language-fallback.html

https://doc.sitecore.com/xmc/en/developers/xm-cloud/enable-publishing-language-fallback.html

You have not shared, if you have applied any of those Sitecore configuration patches. From your description, it sounds you have not configured the publishing language fallback.

0

The language fallback feature is now operational in the headless application following an update to the specified keys:

<setting name="ExperienceEdge.EnableItemLanguageFallback" value="false"/>
<setting name="ExperienceEdge.EnableFieldLanguageFallback" value="false"/>

By default, these keys are set to false. To activate the feature, they need to be set to "true". These keys can be located within the configuration file named "Sitecore.Services.GraphQL.EdgeContent.config".

Below is the patch file code that facilitates updating these keys. It is recommended to utilize a patch configuration file rather than directly modifying the keys in the core configuration file:

<?xml version="1.0" encoding="utf-8" ?>
<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/" xmlns:role="http://www.sitecore.net/xmlconfig/role/">
    <sitecore>
        <settings>
            <setting name="ExperienceEdge.EnableItemLanguageFallback">
                <patch:attribute name="value">true</patch:attribute>
            </setting>
            <setting name="ExperienceEdge.EnableFieldLanguageFallback">
                <patch:attribute name="value">true</patch:attribute>
            </setting>
        </settings>
    </sitecore>
</configuration>

This patch file effectively updates the values of the specified keys to enable language fallback functionality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.