I'm getting this error while running ./up.ps1.

enter image description here

Docker is running windows container. IIS stopped.

  • Did you check if any Firewall is blocking? Disable the firewall and try again. Commented Mar 28 at 7:19
  • What have you tried? Can you give more information here? Its going to be almost impossible to know what the issue is from that screenshot.
    – Richard Seal
    Commented Mar 28 at 13:24
  • 1. cloned fresh xmc solution from github.com/sitecorelabs/xmcloud-foundation-head 2. stopped IIS, stopped all solr services. 3. run these to commands Enable-WindowsOptionalFeature -Online -FeatureName containers –All Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V –All 4. .\init.ps1 -InitEnv -LicenseXmlPath C:\license\license.xml -AdminPassword b 5. .\up.ps1 got error on 5th step also no firewall enabled
    – user14296
    Commented Mar 28 at 14:15

1 Answer 1


Found multiple possible solutions as below -

  1. Run Windows Powershell as "Administrator" and run the following commands to enable containers and Hyper -V. Restart machine after executing the second command -

Enable-WindowsOptionalFeature -Online -FeatureName containers –All

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V –All

Reference: https://stackoverflow.com/questions/57431890/error-response-from-daemon-hcsshimcreatecomputesystem-the-virtual-machine-co

  1. This issue can be due to not having enabled Hyper-V Services in Windows Features.

    Searching Turn Windows features on or off led to enable this option, which worked after reboot. Reference - https://github.com/moby/moby/issues/40720

  • It didn't worked, also I've already run these commands before setup.
    – user14296
    Commented Mar 28 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.