I am trying to rebuild xdb. However, it is stuck on 20.97% from past 4 days. No Error in log file. enter image description here

The solr is stopped on the 4742794. But keeps on saying lastmodified a minute ago.

enter image description here

I have tried out restarting Xconnect web application and Sorl Azure Service. Even JVM is not an issue as seen in below screen short.

enter image description here

can you please help.

  • I'm afraid the only option is to restart xconnect and restart rebuild
    – Marek Musielak
    Commented May 7 at 7:10

2 Answers 2


Please check the current utilization of JVM Memory of your Solr Instance. I faced this once in the past, when my JVM Memory in Solr Dashboard was showing to have consumed 95% and everything was getting slow, even the results on the page. If this is the case, increase the Solr JVM Memory to consume more RAM and this might be faster. enter image description here Technically, what happens is because the Memory is already occupied by other indexes, rebuild might get a very small chunk of the RAM and hence be slow.

Check if the same helps. I faced this challenge with a project in the past, with Solr Cloud in the architecture. Here is an article, might not relate to you directly, but might help in understanding how it worked https://blog.varunvns.in/2019/09/10/solr-cloud-is-super-slow-or-not-responding-search-functionalities-not-working/

If you need to increase the JVM Memory, you can check out the following Stack Exchange link: How to increase Solr JVM memory

Hope this helps.


Successfully achieved functionality. Sequential steps are outlined for implementation. Refer to the detailed explanation available in This link

In Summary:

  1. We have to follow This link for SOLR changes.
  2. We need to follow This Link to understand the changes to be done on XConnect.
  3. The detailed explanation contains changes based on my environment configuration of Azure SOLR.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.