4

We are currently using Sitecore 10.3 XM in containers. After deploying on the CM environment, we have noticed that the languages option does not appear in the publishing dialog on some lower and higher environments.

It happens randomly and is surprising because if we redeploy the code, which restarts the containers, the language option reappears. However, this requires us to repeat the entire deployment cycle as we are working with containers and not on PAAS.

enter image description here

Sitecore has acknowledged this as a known issue, but their recommended solution did not work for us. The only solution that worked was to redeploy the code which eventually restart the containers

https://support.sitecore.com/kb?id=kb_article_view&sysparm_article=KB1003096

Would anyone who has experienced a similar issue be willing to share their thoughts or solutions?

2 Answers 2

1

I believe this is an old issue and different set ups have different solutions,

  1. Because it deals with site being in 64x bit mode, sometimes ASP.NET temporary files gets corrupted and you might need to clean them

  2. If you are on containers, because Step-1 might not be feasible, Instead of completely repeating deployment cycle, just restarting CM instance / pod / container also gets the languages back

I am sure you must have tried the option-2, I have had these issues in an earlier version too, but restarting the instance gets it back

Let me know

1
  • Yes, we have tried restarting and it works similar to a new deployment. The language option becomes available after doing either of the above. However, I am curious if anyone has experienced a similar issue and discovered a permanent solution to prevent this random behavior. Commented May 10 at 9:15
0

I've experienced the same problem with a Sitecore 10.1.1 on PREM. The solution was the one proposed already in the article that was mentioned https://support.sitecore.com/kb?id=kb_article_view&sysparm_article=KB1003096 After I have applied the proposed fix

  1. As a user with Administrator privilege, open the Content Editor in the context of the master database.
  2. Navigate to the /sitecore/System/Languages/en item.
  3. On the Configure tab, Click Unprotect Item.
  4. Save the item.
  5. Click Protect Item.

Also, what I have noticed that if I go to CmHostname/sitecore/admin/cache.aspx page and clear all the Sitecore caches it resolved the issue for me. Does this happen to you too?

1
  • The solution provided in the article by Sitecore should work in most cases, as you mentioned it worked for you. However, it did not work for us. Did you experience the issue reoccurring after a few deployments? We noticed it happening randomly, but it's worth noting that we are using containers. Commented May 17 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.