1

The Add New Member option is missing from the Schema page.

enter image description here

I have been investigating one of the issues in our Content Hub environment. I tried to recall the steps when I encountered a similar issue, but it resolved itself automatically after some time.

Here are the steps I followed:

  1. Go to the M.content schema using the Schema option from the dashboard.
  2. Select the Settings option from the three-dot menu at the top right corner.
  3. Enable the Taxonomy-enabled definition.

enter image description here

After enabling this option, the Add new member button disappears, along with the Settings option, making it impossible to disable the setting again. The above screenshot I have taken from different CH environments to elaborate on the issue.

1
  • could you help me understand why you were trying to convert M.Content schema into a taxonomy enabled definition? Is it by accident or some other reason? Commented May 28 at 20:40

3 Answers 3

1

I tried the same steps in two of our environments as you mentioned above, but I was not able to replicate the issue.

As you mentioned, it resolved itself automatically after some time. This could be because Content Hub runs some background jobs, and when you enabled the taxonomy definition, the process might have been in the queue, preventing any schema changes. Once the queue was cleared, the issue resolved itself.

I have faced similar issues when multiple background jobs were running, which temporarily stopped the rendition creation, but once the queue was clear, the renditions were created successfully.

7
  • Thanks, @Gautam. I have discarded all the schema changes, but the issue still hasn't been resolved. It's been almost 14 days, and I've been checking with support as well. I thought if anyone has faced the same issue, there might be a possible solution. Commented May 28 at 9:07
  • If you enable the "Taxonomy-enabled Relation" and click save, still you able to see the Add new Member option? Commented May 28 at 9:09
  • Can you please confirm that you are logged in as a Superuser and let me know which version of Content Hub you are using?
    – Gautam
    Commented May 28 at 11:27
  • Yes, it's a Superuser, and its the latest version of CH. Commented May 29 at 1:06
  • @HimmatSinghDulawat did you try clearing the cache in Content Hub? Sometimes it could be that the old, cached page is shown, and you need to clear it to display the new changes. Commented May 29 at 14:11
0

Can you check if you have the privileges to modify taxonomy definition as below.

enter image description here

Since you turn on the Taxonomy enabled definition flag, it turns the entity to taxonomy and hence the issue might be happening.

Hope this helps!!!

1
  • Thanks, @ckhanna, my user belongs to the Superuser, and 'Superusers' always have full rights. Commented May 29 at 1:08
0

With this Free Modeling license disabled, we will be able to insert new members and use the content type functionality. However, setting Taxonomy-enabled definition to true while not having the license is breaking this functionality.

If Free Modelling was enabled, then there would be no issue even when setting Taxonomy-enabled definition to true.

Sitecore has filed a report to the product to address this issue ( Functionality breaks when the license is not granted and Taxonomy-enabled definition is set to true)

Now only workaround to this is to use devTools/remove the CSS( display: none) and set Taxonomy-enabled definition to false while having devTools open.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.